Vero 4k - keeps buffering, videos unwatchable :(

Hello everyone,
Its been a while since I bought the Vero 4k, since I moved to a new house.
It was working perfectly the last time I used it (different house, same harware/environment), but now - it just keeps buffering when streaming a video over a wired network.
The videos are streamed from a Win10 machine, with a Samba share.

This is what I tried so far, none helped:

  • Updated to the latest version of OSMC
  • Factory reset everything, (by moving the Kodi directory via ssh)
  • Outrule the ethernet cable/port/speed/etc. by connecting a laptop to the very same cable and port, and then stream a video from the same Win10 machine/SMB share - worked just fine. this outrules the ethernet as the cause.
  • Tried a lower res video (720p) - same issues

Is there anything else I can do? any ideas?
I really want to get the device finally working like it used to…

Thanks a lot in advance!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for your prompt reply!

Here’s the log, as instructed: rebooted twice after setting the log, then started streaming a video file (“The.Gentlemen.2020.1080p.AMZN.WEB-DL.DDP5.1.H.264-TEPES.mkv”), it started playing the very first few seconds without an issue, I was hoping that the problem vanished, so I skipped a few minutes into the movie - and then it started buffering, and the video froze (with a “buffering” notification).
I then went to play another video file (“Long.Shot.2019.1080p.BluRay.TrueHD7.1.Atmos.x264-FuzerHD.mkv”) and right away - buffering, and the video froze.

Here are the logs:
http://paste.osmc.tv/ijenuniyob

Thanks again,
David

Not directly related to your issue but:

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Also what kind of audio setup do you have? Maybe you want to review your audio settings?

https://discourse.osmc.tv/t/connecting-up-your-audio-setup-audio-settings

Last but not least, you might want to check the throughput between the Vero and your PC with iperf3 and/or switch the Samba share to fstab or autofs mounts.

Thanks for your tweaks! :slight_smile:
My OSMC is now configured as you instructed.

I also ran a iperf test:

osmc@osmc:~$ iperf3 -R -c 10.0.0.2
Connecting to host 10.0.0.2, port 5201
Reverse mode, remote host 10.0.0.2 is sending
[ 4] local 10.0.0.7 port 38675 connected to 10.0.0.2 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 8.19 MBytes 68.7 Mbits/sec
[ 4] 1.00-2.00 sec 11.2 MBytes 94.1 Mbits/sec
[ 4] 2.00-3.00 sec 11.3 MBytes 94.5 Mbits/sec
[ 4] 3.00-4.00 sec 11.3 MBytes 94.7 Mbits/sec
[ 4] 4.00-5.00 sec 11.3 MBytes 95.0 Mbits/sec
[ 4] 5.00-6.00 sec 11.3 MBytes 94.8 Mbits/sec
[ 4] 6.00-7.00 sec 11.2 MBytes 93.9 Mbits/sec
[ 4] 7.00-8.00 sec 11.3 MBytes 94.5 Mbits/sec
[ 4] 8.00-9.00 sec 11.3 MBytes 94.7 Mbits/sec
[ 4] 9.00-10.00 sec 11.3 MBytes 94.9 Mbits/sec


[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 110 MBytes 92.2 Mbits/sec sender
[ 4] 0.00-10.00 sec 110 MBytes 92.1 Mbits/sec receiver

iperf Done.
osmc@osmc:~$ iperf3 -c 10.0.0.2
Connecting to host 10.0.0.2, port 5201
[ 4] local 10.0.0.7 port 38677 connected to 10.0.0.2 port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 12.9 MBytes 108 Mbits/sec 0 268 KBytes
[ 4] 1.00-2.00 sec 11.3 MBytes 95.0 Mbits/sec 0 269 KBytes
[ 4] 2.00-3.00 sec 11.3 MBytes 94.8 Mbits/sec 0 269 KBytes
[ 4] 3.00-4.00 sec 11.3 MBytes 94.7 Mbits/sec 0 271 KBytes
[ 4] 4.00-5.00 sec 11.4 MBytes 95.4 Mbits/sec 0 271 KBytes
[ 4] 5.00-6.00 sec 11.3 MBytes 94.8 Mbits/sec 0 271 KBytes
[ 4] 6.00-7.00 sec 11.3 MBytes 94.4 Mbits/sec 0 271 KBytes
[ 4] 7.00-8.00 sec 11.3 MBytes 95.1 Mbits/sec 0 271 KBytes
[ 4] 8.00-9.00 sec 11.3 MBytes 95.0 Mbits/sec 0 271 KBytes
[ 4] 9.00-10.00 sec 11.3 MBytes 94.6 Mbits/sec 0 271 KBytes


[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 115 MBytes 96.2 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 113 MBytes 95.0 Mbits/sec receiver

iperf Done.

I was hoping that after the resolution change the issue might be sorted, but unfortunately - its still there, videos cant be watched properly :frowning:

Also what kind of audio setup do you have? Maybe you want to review your audio settings?

About my audio setup: Since I just moved into the new house - I currently use the TV’s speakers, but I’m going to buy a new audio system in the near future, and I’ll be following the link you provided!

Any other ideas?

Thanks a lot!

As you only have a 100M connection you might benefit from using fstab/autofs mounts while normally with 100M you should not have any problem what so ever to play 720/1080 files.


Have you tried playing the file from local storage?

1 Like

@jitzzz totally forgot that. Before changing the network try to play it after you copied the file to the local emmc.

Just finished installing autofs - works fine! no more buffering! :slight_smile:
This solved it for me…

@fzinken, @sam_nazarko & Tom_Doyle
Thanks a lot for your help!
(sorry, Tom, for not tagging you, I have a 2-users-mentions limit, since I’m a new user )

Would you guys mind to explain why autofs solved it for me?
When trying watching the same movies from a laptop connected to the same cable & port - it played just fine.
How are the speed rates reported by iperf? is my network slow?
Should the autofs fix work just as well for 4k content?

Thanks a lot!

2 Likes

Kodi shares are slower and have more overhead than system mounts. They also don’t support read-ahead.

Well the Kodi internal implementation of samba access is not as performant as the kernel based mounts. We normally would expect an impact of 10-20% but I am really suprized that it had such a big impact to give you trouble on 720/1080 contents.
The autofs solution is surely better and will help for 4k. But even with that certain 4k files might give you issues with the 100M connection but that would be really “special” files.

@fzinken @sam_nazarko
Thanks guys! much appericiated!