Vero 4k+ problem with fast forward and rewind

I am using the latest version of OSMC
When I play movies from an SSD connected via USB port
occasionally, when I try to fast forward or rewind the video stops
and images does not move and I have to stop and restart.
1080p or 2160p, large file or small size = all the same

Primarily, I use my TV remote to control the Vero 4k+ box
Occasionally I use the Kodi remoe app on my android phone
Same problem regardless of which remote I use.

This never happened with my previous Kodi box

Q: What is the proper word for “rewind” since we do not have VHS tapes anymore?

Rewind is still a proper term despite it being used outside of its original context. All the optical disks kept the term even though none of them spun the opposite direction when they were told to play in the reverse direction.

Kodi on most platforms is not actually great in utilizing the ff/rw functions and therefore they recommend to use the “skip step” actions instead. This is the function that happens when you press the direction keys during playback. You can read more about it here…

TY for the response.
I have been using XBMC since the time of the original XBox
I have used Kodi on an Asus Chromebox for 8 years or so.
I have never had a problem until buying this Vero 4k+

Fast forward and rewind worked okay on the original Xbox which was a good thing since skip step didn’t exist at that time. It also still works okay on some platforms, but just some. On the Vero it will also be likely impacted if not using optimal playback setting…

Click to see recommended settings

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

But even if it happened to work well I personally believe skip steps work better from a user interface perspective once you get used to using the direction keys to navigate this way. You may need to tweak them a bit to get them to your preference (I prefer the initial small steps to be +30 and -15) and that is described in what I linked to earlier.