Vero 4k regular crashes in idle

4.9 should have better thermal governing which stops this happening entirely, but I also recommend a reinstallation.

Have you tried just resetting Kodi?

systemctl stop mediacenter
mv .kodi .kodi.save
systemctl start mediacenter

That will set Kodi to defaults.

That will set Kodi to defaults.

Thank you, very helpful, but not in my case, as it seems. Reset Kodi to defaults, re-scanned library, watched a movie, temperature again rising.

I also recommend a reinstallation.

Are the steps here (https://osmc.tv/wiki/vero-4k/reinstalling-osmc/) still valid? And – is there any possibility that I can backup and restore the bluetooth pairing between my Logitech Harmony and Kodi?

Is the Harmony active during your tests? If so, can you turn it off and test without the Hamony?

Turn the Harmony off or turn the Harmony off in Kodi?

If you can, just turn the Hamony off and use the OSMC remote.

Unplugged the power from the Harmony Hub, rebooted Vero, used the OSMC remote, watched a movie, comes back to the episode screen, temperature rising again.

As already suggested, I think a full reinstall would be the next step. Hopefully someone can answer your question about backing up the bluetooth config as I don’t know.

Doesn’t matter, it’s not working with the Vero anymore after I unplugged the power from the hub and rebooted the Vero.
Is the reinstallation guide up-to-date?

Edit: at least a step like “save the image to…” is missing.

Edit2: I am on Linux. So I assume I have to gunzip the disk image. Are there any special block size or other parameters necessary to dd it to an SD card?

Edit3: installation guide for Linux command line:

  1. Go to the Download page and klick on “Disk Images”. Find your device and right-click and save the latest image to your computer.
  2. In a terminal, change to the download directory and use ‘gunzip OSMC_TGT_vero3_20200607.img.gz’ to extract the image.
  3. Insert an SD card or USB stick into your computer.
  4. Using e. g. ‘dmesg’, find the device name of the SD card or USB stick, e. g. ‘/dev/sdf’. Be sure to pick the correct one. All data on that device will be overwritten with the following command.
  5. Use ‘dd if=OSMC_TGT_vero3_20200607.img of=/dev/sdX bs=1M conv=fsync’ to write the image to the SD card or USB stick.
  6. Remove the SD card or USB stick from your computer.
    (continue with step 4 from the reinstallation guide).

Reinstalled Vero with the 2020-06 image. Installed vim and autofs. Mounted NFS shares. Scanned the TVShows share. Watched a movie. (Skipped 50min forward). At the end, Vero came back to the episode overview, and in no time the temperature went up again. Manually switched to the series overview screen, temperature coming down again.

TIME:21:15:29: 78000
TIME:21:15:39: 89000
TIME:21:15:49: 89000
TIME:21:15:59: 93000
TIME:21:16:09: 93000
TIME:21:16:19: 95000
TIME:21:16:29: 95000
TIME:21:16:39: 96000
TIME:21:16:49: 96000
TIME:21:16:59: 97000
TIME:21:17:09: 96000
TIME:21:17:19: 99000
TIME:21:17:29: 101000
TIME:21:17:39: 101000
TIME:21:17:49: 100000
TIME:21:17:59: 100000
TIME:21:18:09: 101000
TIME:21:18:19: 102000
TIME:21:18:29: 102000
TIME:21:18:39: 103000
TIME:21:18:49: 104000
TIME:21:18:59: 104000
TIME:21:19:09: 105000
TIME:21:19:19: 104000
TIME:21:19:29: 105000
TIME:21:19:39: 105000
TIME:21:19:49: 106000
TIME:21:19:59: 108000
TIME:21:20:09: 107000
TIME:21:20:19: 107000
TIME:21:20:29: 107000
TIME:21:20:39: 107000
TIME:21:20:49: 103000
TIME:21:20:59: 95000
TIME:21:21:09: 96000
TIME:21:21:19: 95000
TIME:21:21:29: 92000
TIME:21:21:39: 94000

This time, the series had no scrolling episode desciption, but the episode name was scrolling sideways. I found an episode of Mr. Ed which does not scroll horizontally nor vertically. Temperature rises, too. However, there is metadata in the bottom left corner which changes (aspect ratio, language, …). Can that be the culprit?

BTW, just for the records, the Vero is sitting on top of a TV rack and has lots of air around.

Just wondering does it also happen if you just go to the Season view with something scrolling right after reboot without watching a movie?
But I am really running out of ideas, maybe the connection to the cooling plate got wrong.

Alternatively you could try using the 4.9 Kernel which has enhanced governance control. But I am still not sure what is going on on your device.

Just wondering does it also happen if you just go to the Season view with something scrolling right after reboot without watching a movie?

No, it doesn’t. I booted, went to an episode, and the temperature was between 80 and 89.
Had the movie play: 79-83
The movie ended: went to 117 in 15 minutes and then the ssh connection broke.

This is already kernel 4.9 to which I upgraded right before this test.

As a last resort, I changed to the Estouary (default Kodi) skin. And voilà: temperature stays at 80.

This is all still strange. If I stand on a season with scrollng text I have Kodi at 72% - 85% CPU. But the temp is stable around 82c.

On which skin was that?

OSMC skin.
Which one were you using?

The same, OSMC. Strange.

I mean, I was using the OSMC skin for performance reasons and because other skins reacted sluggishly or crashed on me. So I’ll simply give Amber or Nebula a try again.

@jan.stuehler After reinstallation of OSMC, do you remember what customizations you did with the OSMC skin?
I spent some time to reproduce this issue and even created a dummy Tatort_407_s1999e05 file to get the same scraping meta data from TheTVDB.com … but here the temperatur stays at 75°C.
Current deltas I see so far

  • unknown list of addons installed with your device
  • unknown skin settings
  • not using (this special mp4)
  • not using NFS
  • not using the specific TV and Vero HW in your env.

@JimKnopf, after reinstalling, the only changes I made were installing vim and autofs, and scanning TV shows from the NFS shares. I switched the mode from “Beginner” to “Expert”. And during installation, I set the language to German, connected the Wifi, and started the ssh daemon.

After reinstallation, I did not install addons, I did not change the skin settings apart from the language.

Edit: activated the Amber skin now. Found an option to activate scrolling descriptions. Activated that. Temperature comes up to 101, but not higher. (Will de-activate that option again later because I anyway don’t need scrolling descriptions).