Vero 4k - Sad Face Loop after Kodi 19 Upgrade

I have a sad face loop after upgrading my Vero 4k to Kodi 19. I tried removing the userdata directory as suggested in the [TESTING Kodi v19 build for Vero 4k / 4k + thread which resulted in a black screen / no-signal. I also tried purging libegl-mesa0 which was suggested in another support thread, but it didn’t fix things.

The issue seems to be associated with the error below. Full logs, here:

If anyone has any ideas for fixing this issue it’d be appreciated. Thanks.

2021-08-07 21:11:22.113 T:8776     INFO <general>: Found (1920x1080@24.000000) at 24, setting to RES_DESKTOP at 16
2021-08-07 21:11:22.113 T:8776    ERROR <general>: GetString: error reading /home/osmc/.kodi/userdata/disp_cap_3d
2021-08-07 21:11:22.113 T:8776  WARNING <general>: Update3dResolutions: No valid 3D resolutions found.
2021-08-07 21:11:22.120 T:8776    ERROR <general>: failed to initialize EGL display (EGL_BAD_ALLOC)
2021-08-07 21:11:22.605 T:8776    FATAL <general>: CApplication::CreateGUI - unable to init windowing system
2021-08-07 21:11:22.606 T:8776     INFO <general>: Stopping player
2021-08-07 21:11:22.606 T:8776     INFO <general>: Stopping all
2021-08-07 21:11:22.612 T:8776     INFO <general>: stop dvd detect media
2021-08-07 21:11:22.613 T:8776     INFO <general>: Application stopped
2021-08-07 21:11:22.813 T:8776     INFO <general>: unload skin
2021-08-07 21:11:22.813 T:8776     INFO <general>: Unloaded skin
2021-08-07 21:11:22.813 T:8776     INFO <general>: unload sections

Running apt-get update and apt-get dist-upgrade should solve your issue.

In the unlikely event it doesn’t, please post full logs after updating again.

You could try upgrade via cli
sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot

This will solve your issue.

It’s working now. Thank you both for the quick reply.

1 Like

I have the same issue - looping sad face. I’ve never connected to Vero through CLI. Tried it now and I get “Access denied” error when I try to log in. I use “oscm” both for login and password. What am I doing wrong?

Did you type the above or osmc for user and password?

Glad to hear this.

Never mind. I tried “osmc”, not “oscm”. But seems like I changed the password long time ago and forgot about it. I managed to update through CLI and it seems to be working fine. Thanks!

Sorry I’m completely lost. I never used any commands so far and the sad face keeps on looping.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Thanks but i don’t have a connected keyboard and I’m not familiar at all with SSH.

Unfortunately that is in the current status your device is in the only option to ensure that you keep your settings/configuration.
Alternatively if you don’t mind loosing your configuration you could do a reinstall

An error has occured while writing the image. I can’t even re)install a past version. I’m tired… and where is the log file ? Why things cannot be easy ?

What should be the format of the USB key ?

Format will be automatically overwritten by the installer. should be FAT after the USB is written.
Means if you plug in Windows should see some files. maybe can post the content of the USB stick here to validate.

Thanks Fzinken. I’m on Mac. Once it want to copy the image on they USB key, it does not work. It says an error occured and I should look at the logfile but where is the logfile ?

As far as I know the installer on Mac is not working but maybe @sam_nazarko can comment.

The macOS installer should be updated later today with any luck.

If you have a Windows PC, that’ll probably be a quicker route to get up and running

It’s booting up properly now, but I’m having another problem after upgrading to kodi 19. There’s no audio in the menus or during playback. The audio is normally output over HDMI to an A/V receiver.