Vero 4k - Sad Face Loop after Kodi 19 Upgrade

I’m not having any luck troubleshooting the audio problem on my own. Is this part normal:

2021-08-08 06:25:32.217 T:3344     INFO <general>: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2021-08-08 06:25:32.217 T:3344     INFO <general>: CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4

Can you try on another TV other than the Vizio as a test?


I’ve tested it on a Samsung TV and I do get audio.

Can you post a log from that Samsung?

Did you use the same HDMI cable?

Here’s the log when connected to the Samsung TV:

The previous log used a different cable but I’ve since swapped cables and simplified the connection. Same HDMI cable and same setup (Vero 4k connected directly to TV with the same HDMI cable).

Not really a solution, but I’ve got things in a good-enough state for now by hooking up an old receiver between the Vero 4k and the Vizio TV. The receiver doesn’t support 4k so I lose that ability, but at least the audio is working.

I would be curious to know why audio doesn’t work with the vero connected directly to the Vizio TV, but at this point it’s more of an annoyance than a problem so don’t worry about it.

We’ll investigate this shortly


Hey guys, after update, my vero4k is stuck at sad smiley face. I am trying to fix it , but no luck. Any suggestions, i have tried mentioned ssh commands, but no luck :frowning:

Did you tried the removal commands in this thread?

Removal commands? :slight_smile: I didn’t, i reset everything now, unfortunatelly i lost a library settings and stuff, but at least it’s working now.