Vero 4K SD or USB Reinstall procedure does not work

After enjoying good time with Vero 4K. Now start the trouble.
So, I unsuccesfully tried to reinstall OSMC by following the procedure Reinstalling OSMC - Vero 4K - OSMC
The outcome is either that

or that

See a pics my toothpick in place

I also tried using a USB key instead of an SD card as explained at the end of Buggy Vero 4k System wipe issues - #6 by sam_nazarko

Any more detailled procedure or idea to bring my Vero 4K back to life!

The toothpick shouldn’t really be necessary for the Vero 4K.

Do you ever see the OSMC installer come up? You should see something like ‘Formatting Partitions’ etc.

It currently doesn’t work from USB (unless you use that image I posted), so you need to use an SD card. We had a user recently putting in the SD card the wrong way.


Hi, I did use the toothpick because the other one did not work.

The other result was:

For the USB, I used your image according to your link Dropbox - File Deleted

For the SD Card, I put it the right way.

As I never get “Formatting Partions”, do you have a pics of OSMC installer display ?

That menu is being displayed because the installer is not being read from the SD card. Either the SD card is not readable; or the necessary files to kick off reinstallation are not present.

How did you image the SD card?
Can you plug it in a PC and show us the contents of Explorer?

There is only one file in my SD card (formated in FAT32): recovery.img
Should I use a tool such as Win32DiskImager like for raspberry ?

I don’t believe you’ve imaged the card correctly, which is why the installer isn’t running.

You should use the official OSMC installer here.
Or you can use a tool like Win32DiskImager.

This is explained in the Wiki.

Now it works! Thanky you.
I totally misunderstood the instruction in Reinstalling OSMC.

No problem. I am glad we got this resolved :slight_smile:



clearly i am misunderstanding those instructions too. and what wiki are we talking about? i have been struggling all day to make a useable boot disk to recover my vero4k+

that website with the downloads is very confusing. do i download disk image or linux link (which takes me to 4 options, is the vero4k AMD or 386. is it even 64 bit? debian 7 or 8?)

i am doing this on a mac, which doesn’t always identify when a file needs to be unzipped so could the guide pls say when an unzip is required…

Download the installer for OS X which then will download the image and put it on the SD card or USB stick for you

Looking to reinstall OSMC on my Vero 4K since its been quirkly lately. I followed the instructions in the link below using a 16GB USB stick, but the Vero 4K simply boots into OSMC without starting any reinstall procedure. I tried both USB ports. What’s the trick?

Can you show the content of the USB stick?
Do you by any chance have a second USB stick to try?

I tried an 8GB USB drive and that one worked.