Vero 4k+ & SMB on win7: Errdos ERRnomem error

Hi all,

My vero4K+ arrived today, setup was very smooth but when trying to find the SMB shares (they are on a win 7 machine) using fstab, the drives still are not found.
When trying to find a SMB drive in Kodi itself, nothing was found and the wiki led me to using fstab

If I try to use smbclient to connect to the machine, I get the error “protocol negotiation failed: ERRDOS: ERRnomem”

Logs are available here:
https://paste.osmc.tv/cudafanodi

The network drives can be accessed, I currently have another HTPc running (a win 10 + kodi machine) and there using SMB works.

I tried a fix I found here:
https://www.dedoimedo.com/computers/windows-7-samba-errnomem.html
But this didn’t solve the problem.
SMB1 was enabled via powershell in Win7 but this too didn’t fix the issue

I got a bit further:
using smbclient -m smb3 -U osmc -L 192.168.0.233 I got logged in

This is what it shows:

Domain=[DATAPC] OS= Server=

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    E               Disk
    E$              Disk      Default share
    F               Disk
    F$              Disk      Default share
    Films           Disk
    IPC$            IPC       Remote IPC
    Series3         Disk
    Users           Disk

Have you seen: File sharing with a NAS, media server, windows share or other device

Yes, went throughe that page and the pages it links to (Configuring fstab based Samba share mounts)

Tried different options there (like adding the SMB version to fstab, but nothing seems to help so far

Did you specify a user/password?

Yes,

I got it working in the meantime. Will share the solution here in case it helps another user:
First, I had to share both my drive and my folder with user “osmc”, created on my win 7 server. So Drive E and folder “Films” was shared with read/write rights for that user

Then, I had to enter the following in fstab:

//192.168.0.233/E/Films /mnt/Films cifs defaults,vers=2.0,username=osmc,password=password,x-systemd.automount,noauto 0 0

The version 2.0 of SMB and the sharing of both drive and folder seems to have fixed the issue, I can now mount the drive and via ls I can see the content

2 Likes

SMB 3.0 was introduced with Windows 8, Windows 7 shipped with 2.1 and upgrading is not possible because of the integration in Windows.
Probably explains why your initial config works on the Windows 10 pc and not on your 7 PC/server :wink:

1 Like