Vero 4k+ TVHeadEnd UK Freeview playback jerky

I’m using two OSMC ‘DVB-T2/DVB-C TV’ dongles and a powered USB 3 hub on my Vero 4k+, acting as both a server and a client.

My playback (and recordings) all seem to be jerky - they look like they speed up and then slow down, regularly, each second, so any movement looks awful (especially sports).

Any ideas? I’ve tried all sorts of settings over the last few days, but I’m just getting lost in it all now…!

Thanks (in advance)!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


(or that’s what the Log Uploader screen shows - I have no idea whether that’s what I’m supposed to provide, or if I’m supposed to do something else now… the instructions are a little confusing for me, and that URL gives me a whole lot of nothing when I try to access it!).

I’ve corrected your link.

1 Like

You need to let Vero output video in the resolution and refreshrate of the video stream. As a minimum:

  • set your GUI resolution to 1920x1080 50hz
  • set Settings->Player->Videos->Adjust display refresh rate to ‘On start/stop’ - You will still get 4k video playing as 4k.

That should fix things but you may have a better experience using the whitelist so that SDTV plays in its native resolution. For that have a look here.

1 Like

Awesome shout. Thank you!

I’d pretty much got there just after you’d posted (I’ve been annoying my wife and kids, playing around with the TV and Vero constantly all morning) but it gave me the confidence that I was now working along the right lines, as I’d mis-used the whitelist (thinking the highlighting worked in reverse!).

All now working perfectly in time for the wife to watch her nation’s rugby team (and hog the TV). :slight_smile:

1 Like