Vero Crashes Daily when Accessing Windows Shares

Can you leave the PC on for one night and let us know if it still happens?

Sam

I’ll try both suggestions and report back.

Still crashing. Not every single day, but more often than not. Here are the logs I grabbed right after resetting. Sorry if it’s more than you need. I wasn’t sure what to select.

https://paste.osmc.tv/ewajahital

Did you find that keeping the PC on reduced the incidence of the problem?

Sam

Yes, crashes are less frequent when the PC is not turned off.

Try using autofs

I spent a couple of days on the autofs setup and just can’t get it work. Testing it just results in " No such file or directory".

For now, I’m going back to fstab and the hard reset of my Vero every day.

Show us what you’ve tried with autofs. I’m sure we can help you.

I followed the instructions. This is the line I added:

/mnt/Computer/TV -fstype=cifs,rw,username=AcutalName,password=ActualPass,iocharset=utf8,uid=osmc,gid=osmc ://192.168.1.104/tv/

My computer is named “Computer”. I have a single shared folder named “TV”.

I should have asked for the fstab line also.

This is the fstab line that works for me:

//192.168.1.104/tv /mnt/TV cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=ActualName,password=ActualPass,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

The auto.map line looks OK. What does your auto.master look like?

for auto.master, I just pasted

/- /etc/auto.smb.shares --timeout 15 browse

Did you try:

sudo systemctl stop autofs
sudo automount -f -v -d

that should show why the mount is failing.

Here’s what I get:

osmc@Vero:~$ sudo automount -f -v -d
Starting automounter version 5.1.2, master map /etc/auto.master
using kernel protocol version 5.02
lookup_nss_read_master: reading master file /etc/auto.master
do_init: parse(sun): init gathered global options: (null)
lookup_read_master: lookup(file): read entry +dir:/etc/auto.master.d
lookup_nss_read_master: reading master dir /etc/auto.master.d
lookup(dir): dir map /etc/auto.master.d missing or not readable
lookup(file): failed to read included master map dir:/etc/auto.master.d
lookup_read_master: lookup(file): read entry +auto.master
lookup_nss_read_master: reading master files auto.master
do_init: parse(sun): init gathered global options: (null)
lookup(file): failed to read included master map auto.master
lookup_read_master: lookup(file): read entry sudo
syntax error in map near [ sudo nano ]
no mounts in table

Have another look at your auto.smb.shares and auto.master :wink:

Still not working:

Starting automounter version 5.1.2, master map /etc/auto.master
using kernel protocol version 5.02
lookup_nss_read_master: reading master file /etc/auto.master
do_init: parse(sun): init gathered global options: (null)
lookup_read_master: lookup(file): read entry +dir:/etc/auto.master.d
lookup_nss_read_master: reading master dir /etc/auto.master.d
lookup(dir): dir map /etc/auto.master.d missing or not readable
lookup(file): failed to read included master map dir:/etc/auto.master.d
lookup_read_master: lookup(file): read entry +auto.master
lookup_nss_read_master: reading master files auto.master
do_init: parse(sun): init gathered global options: (null)
lookup(file): failed to read included master map auto.master
lookup_read_master: lookup(file): read entry /-
master_do_mount: mounting /-
automount_path_to_fifo: fifo name /var/run/autofs.fifo–
lookup_nss_read_map: reading map file /etc/auto.nfs.shares
do_init: parse(sun): init gathered global options: (null)
st_ready: st_ready(): state = 0 path /-

It is only looking for auto.nfs.shares, not auto.smb.shares.

Paste your entire auto.master so I can look at it.

Also check in auto.master.d. Are there any files there?

auto.master.d is blank. Here’s auto.master

#
# Sample auto.master file
# This is a 'master' automounter map and it has the following format:
# mount-point [map-type[,format]:]map [options]
# For details of the format look at auto.master(5).
#
#/misc  /etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
#       "nosuid" and "nodev" options unless the "suid" and "dev"
#       options are explicitly given.
#
#/net   -hosts
#
# Include /etc/auto.master.d/*.autofs
# The included files must conform to the format of this file.
#
+dir:/etc/auto.master.d
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master

 /- /etc/auto.nfs.shares --timeout 15 browse

You are looking for auto.nfs.shares

Is that what the other file is named?

What is the output of:

ls -l /etc/auto*