Vero4K CEC Seems To Auto Switch Input

Ideally I would like to disable CEC on the TV but then that also disables ARC on my TV :frowning:
Disabling it on the Vero didn’t seem to help

Thing is - if you ahve 2 device controlling your TV, it will do weird things.
I got myself a 42" 4K Computer Screen (No TV tuner), but it has a IR remote. And that one I use only with the remote. CEC completely disabled. My AV Receiver is doing the ARC stuff. It is the central unit controlling it all.

Check the input on your TV where the AVR is plugged into and make sure it is connected to the correct input for ARC. If it is then unplugged everything from the wall for a few minutes to reset the CEC bus and than try it again.

On a side note you can use CEC and Harmony remotes at the same time. You just have to be a bit more careful in how you have all your settings configured and your remote programed but it works fine. For example on my setup because I have CEC controlling power of my AVR I programed my remote so the AVR stays on all the time which makes it so it no longer sends power on or off commands with activities.

Thanks for the response guys. I can really disable CEC on my TV as I need that for ARC to send audio from the TV to the amp.

I may try a full reset of all the devices to see if that helps.

Is there nothing in the logs I pasted that shows what Vero is doing at that point?

I see the following, but I’m not sure if that’s Vero doing something actively or just reacting to an input

    Feb 17 20:56:10 osmc kernel: hdmitx: system: irq 2
    Feb 17 20:56:11 osmc kernel: hdmitx: plugin
    Feb 17 20:56:11 osmc kernel: EDID Parser:
    Feb 17 20:56:11 osmc kernel: hdmitx: get dtd0 vic: 97
    Feb 17 20:56:11 osmc kernel: dump_dtd_info[1794]
    Feb 17 20:56:11 osmc kernel: pixel_clock 24150
    Feb 17 20:56:11 osmc kernel: h_active 2560
    Feb 17 20:56:11 osmc kernel: h_blank 160
    Feb 17 20:56:11 osmc kernel: v_active 1440
    Feb 17 20:56:11 osmc kernel: v_blank 41
    Feb 17 20:56:11 osmc kernel: h_sync_offset 48
    Feb 17 20:56:11 osmc kernel: h_sync 32
    Feb 17 20:56:11 osmc kernel: v_sync_offset 3
    Feb 17 20:56:11 osmc kernel: v_sync 5
    Feb 17 20:56:11 osmc kernel: hdmitx: edid: find IEEEOUT
    Feb 17 20:56:11 osmc kernel: hdmitx: edid: check sum valid
    Feb 17 20:56:11 osmc kernel: hdmitx: edid: check sum valid
    Feb 17 20:56:11 osmc kernel: hdmitx: update rx hdr info 5 at edid parsing
    Feb 17 20:56:11 osmc kernel: hdmitx: edid: check sum valid
    Feb 17 20:56:11 osmc kernel: hdmitx: edid: check sum valid
    Feb 17 20:56:11 osmc kernel: hdmitx: edid: blk0 raw data
    Feb 17 20:56:11 osmc kernel: 00ffffffffffff00068d01007b015dae00190103808e50780aa833ab5045a527
Feb 17 20:56:11 osmc kernel: hdmitx: edid: blk1 raw data
Feb 17 20:56:11 osmc kernel: 020365f05c61101f041305142021225d5e5f6065666264071603123f400f241e
Feb 17 20:56:11 osmc kernel: [RX]-receive ksv list len:1,depth:1,cas:0,dev:0

I repeated the issue again with CEC logging enabled
The issue is around Feb 19 10:38:04 which looks similar to my previous log, but I’m not clear what is really happening then

Did you check that the AVR was plugged into the correct input on the TV for ARC use?

Yep that’s definitely in the correct port

And if you go to (on the Vero) settings>system>input>peripherals>CEC adapter> and turn off the “enabled” option, click OK (and not accidently hit the exit button on the remote instead), and then reboot, the behavior continues?

You might also try settings>system>display>Lock HDMI HPD>[enable]

1 Like

I’ll give that a go, as I’m not sure I rebooted after disabling it last time.

I’ll also try the lock HDMI too if the disable doesn’t work.

Cheers for the tips. Will report back soon

Had that same issue. CEC needed to be enabled on the TV to use ARC. The suggestion given seems to work (disable the CEC adapter, save, and reboot). I had no clue that there was a CEC setting on the Vero.

1 Like

The work around sounds fine (disabling the CEC control on the Vero) however with this enabled it still reads as though its not working properly with CEC.

As I undestand and experience with my setup, when you power on a CEC enabled device the normal behaviour is to for it to take control of the AV Receiver and the TV etc, i.e. display its start up page and select itself as the input device the to the AV receiver. So, is this what you mean by ‘auto switching’, i.e. when powering on the Vero or does it just happen randomly when using the harmony to switch between devices. Sounds to me like the harmony is the culprit …

That is not quite right. CEC, in a broad sense, is just devices with the ability to declare what they are and send requests to other devices that have declared themselves on the bus that they perform some function. OSMC, on all platforms, simply declares itself as a recording device and nothing else with stock settings. If it sees an amplifier device on the CEC bus it will switch from adjusting PCM audio volume to sending CEC volume requests instead, but this is in no way ‘taking control’ over the AVR.

The only time an OSMC device is going to send a request to switch input is if someone has enabled the option in the CEC settings, and that is not on by default. However this does not mean that this isn’t going to happen anyway because a different CEC device told it to. For example an AVR may do it on its own as part of a last connected device powerup setting or a TV may might do it when exiting a web app if the previously used input was a non-CEC HDMI device (my LG will do this).

The whole thing can get even more messy if you have more than one device that is trying to regulate power states and are sending power toggle instead of explicit power commands. If you add a Harmony remote to the mix, which relies on exclusive control so it can keep track of what state everything is in then things get a bit more complicated. This is why Logitech tells you to disable CEC wholesale. This does not mean that you can’t use it, it means that it is a much lower support burden for them to make that recommend.

At the end of the day CEC sucks, but it has its upside, and you can use it and a harmony remote all at the same time. If you wish to do so you should expect to spend some time tweaking things to work out the kinks. For example turn off power control from everything except the TV, which includes programing your AVR in MyHarmony to be an always on device (because CEC on the TV is going to be controlling that). If your going to use the CEC power function in OSMC you tell it to only send to the TV and not the TV and AVR (again, because the TV if going to be controlling that). If you have a TV or AVR that is switching inputs after the Harmony powers up an activity, then you will have to add a delay in the remotes programing before the select input action happens so it doesn’t get preempted.

If all else fails… hit the “help” button on the Harmony remote.

So it seems that rebooting Vero after disabling the CEC module was the key to my issue (I didn’t realise it needed rebooting). It’s no longer switching to the Vero input after I’ve selected another activity.

I have also this issue. I have CEC disabled but still Vero somehow messes with my LG C8 TV - Yamaha Amplifier CEC connection.

It only happens about once or twice per week, but when issue is on CEC is not working between my TV and amplifier. Situation is solved if I reboot Vero or unplug Vero HDMI connector or power cable. Setting Vero to standby does not help.

I tried activating CEC in vero to solve the issue but then I get this forced auto switching to the input on the amplified Vero uses.

I started having more issues with CEC with my TV saying my amp didn’t support ARC…
I went through unplugging devices from my amp and when the Vero was unplugged ARC started working again (I tried connecting and disconnecting serveral times and it would have the same effect).
I’ve since bought one of these CEC less adapters and plugged it into the Vero. So far everything is working fine :slight_smile:


Thanks for the tip! I will try the CEC removing adapter.

That CEC less adapter should do the trick.
CEC is a hot mess now that so many devices support it and want to control everything else.
Just remember, anything with two heads is a freak!
CEC is no exception.
Couple that with the fact that the Vero is designed as an always on device so CEC can get messy real quick.
Personally, I have the Vero setup to go into a screensaver, just a black screen, after one minute of idle and at the same time, if not playing a file, it sends a shut down to TV and AVR.
This might not be for everyone, but this works great for me because if I forget to turn off my TV, the Vero will do that for me automatically and shut down my AVR.
Great insurance for my OLED just incase I fall asleep watching something.
If I pause a video, it fades to black (the screensaver) but leaves the TV and AVR on, which is great if I pause to go the bathroom, and when I come back, hitting any button fades the picture back on and then it’s ready for me to hit play and resume.
Now, the majority of my TV time is with the Vero so this works great.
LG TVs tend to be even pickier than most and I found a great work around.
If my children want to play the Wii U, I grab the Vero remote and hit a button, this wakes up (turns on) my TV and AVR and shows the Vero, then I switch the input on the TV to antenna, then I switch to the Wii U.
For some reason, switching to a input that doesn’t have anything plugged in then switching to the actual target input keeps the Vero from high jacking the CEC and making everything switch back to the Vero.
If I switch from Vero to Wii U, I’ll get the Wii U for a few seconds but then it automatically switches back to the Vero.
Even when disabling CEC and rebooting my setup it would still do that but less often for some odd reason.
The only way to 100% not have it auto switch back to the Vero is to switch to a dead input first .
So in the end, I’m able to have my Vero CEC settings and not have it shutdown or switch back just by switching the input to an unused input first before the actual target input.
Go figure.
This works for switch inputs on my AVR and for built in apps on the TV.
If your cool without the Vero’s CEC function, then that adaptor should be perfect, otherwise try what I mentioned about switching to an unused input first before your target input.

EDIT: Links that may help: No Hdmi ARC on AV receiver when V4K is hooked - #24 by Kontrarian and Vero 4K+ messes with ARC - #68 by pinn73 and HDR Autoswitch causing issues on my LG OLED65C8 - #238 by Kontrarian

Lindy CEC remover now in use and seems to work fine. I had to upgrade the HDMI-cable to a better one, since after adding Lindy adapter to the chain Atmos audio stopped working with 4K content.

1 Like

This seems like a potential solution to the input switching issue that I have been having, thanks!

But before I get the CEC remover, just wanted to check one thing - would my TV remote still be able to control Vero if this remover is active?