VERO4K - Get Context Menu working with new Samsung SUHD TVs (KS8000)

Hello Guys

Can someone please help me to get the Context Menu working on new Samsung SUHD TVs (KS8000) TV remotes?

Image of the remote attached and model details of the TV and Remote as well.

TV Model:
SAMSUNG SUHD TV - KS8000 - 60’’

Remote Model: (Images attached)

Note that I already tried to feed the Long Press on the remote but it’s not bringing the Context Menu…

There’s a key mapper addon for Kodi that I fund useful.

1 Like

I assume shukerr is referring to this:

1 Like

Many thanks @shukerr. I did use it but I can’t get the ContextMenu to work as a long press. I manage to set “6” as the context menu and this mean to trigger it is not “One Button Click”. I need to press numbers button --> Select 6 --> Hit Back button. Then the context menu will work…

Anyone who got similar remote share how use manage to get this working… The button “Extras” is a perfect button to use but whenever I click it TV interface Twitter is coming… Seems to be TV not passing this button vis CEC.

Given lot of latest TVs having small remotes good to know a workaround as I am sure others might face same issue as well…

Think we had a similar thing on Vero 2. This advice might help you: HDMI-CEC some buttons not working on Vero2 that do work on Pi2 - #21 by Dilligaf. It can occur on Samsung TVs because Vero configures itself as a ‘player’, where as a Raspberry Pi considers itself a ‘recorder’. On Samsung TVs the button assignment depends on the role the device presumes.


Thanks @sam_nazarko

I went through your suggestion and VERO4K correctly recorded as a “recorder” and values were as below.

<setting key="device_type" type="int" value="1" configurable="0" />

<setting id="device_type" value="1" />

Then I changed them to “4” and tried but no luck.
Is it anything I can so to send some of these TV remote keys like EXTRA’s to the VERO4K???

When I tried sending keys and capture them via logs even the long press not recorded.

Also Samsung got a program that you can get service providers added to the Samsung device list if you can get VERO4K added to the Samsung TV service in that case all keys will start working. For example I got a foxtel IQ3 box at home and when I search for this in Samsung menu it comes and I can control my Foxtel box via the TV remote. I don’t know it’s CEC or not but it’s working.

Worth asking Samsung to include VERO products in this list.

I think the general rule of thumb is that if Kodi can’t see the keypress, it’s not going to be something you can remap.

But whether OSMC is a Recorder or Player can impact the keys that the TV chooses to send to your device.

  • Can you check if the firmware on the TV is up to date? It’s resolved Samsung TV issues in the past beforehand.
  • Did you reboot after you made the above changes?
  • Comment about the Foxtel is interesting: can you take a few photos so I can see how it looks?


Thanks @sam_nazarko. What are the other values I can try in VEROS device settings as If I can get the Ch up and down keys working I can use it as Context Menu and some other action.

From the video you will see that with Foxtel STB the keys CH up and down working via Samsung Remote and just need to find a way to make these keys send to VERO4K as then I repoint them

Recorded Video on my Samsung TV as below and you can see remote working with Foxtel.

Also answers to your questions:
Can you check if the firmware on the TV is up to date? It’s resolved Samsung TV issues in the past beforehand - Yes FW is up to date as per Samsung SITE

Did you reboot after you made the above changes? YES first TV from the wall socket and then the VERO4K

Comment about the Foxtel is interesting: can you take a few photos so I can see how it looks?
As above

@sam_nazarko Happy EASTER to you and OSMC Team…

Can I kindly get answer to below question as then I can try different codes? Also any luck with Samsung and get VERO4K added to the TV as a device? This menu thing is a real bum… mate.

What are the other values I can try in VEROS device settings?

As a side note changing the device type value to “4” (From 1) fixed one of the annoying issues I had with VERO4K. When ever I restarted the TV or VERO4K if I am in the VERO4K source CEC DID NOT worked unless I swap the sources around with any and come back to the VERO4K source. But after this change that issue was gone… in a way this is a small WIN for me.


Sorry for the late reply.

From above, it looks like Samsung is actually responding to the Foxtel remote’s codes rather than using CEC. If it was using CEC, I wouldn’t expect it to prompt for you to select and configure the device.

Unfortunately I don’t have a Samsung TV at hand to test this. There have been some reports of not all buttons working properly with Samsung TVs. Hopefully we can hope this is resolved in libCEC at some point in the future.

Try enable debug logging, press the key you’d like to work on your remote. If it’s getting through to Kodi then we can remap it to work as a context menu key; if it’s not, then it means the TV isn’t passing the key through to OSMC.


Thanks @sam_nazarko

I was asking what other codes I can use for below Values to test it out? Reason is if I can find the code to trick SamsungTV TV that, VERO4K is another FOXTEL Box then other keys will start to work… Given I don’t know what other values are seeking your help…

<setting key="device_type" type="int" value="1" configurable="0" />

<setting id="device_type" value="1" /> 

I will report this as a BUG to samsung as well…Coz each time I reset my VERO4K the source name I setup in the TV as VERO4K getting reset to default TV source name.

No – it won’t work like that.

I am almost certain that the Foxtel menu setting is actually configuring the Samsung device for IR, not CEC. It’s worth us checking if those CEC codes are being sent to Vero 4K however. If you enable debug logging and press the key a few times, we’ll be able to see if OSMC’s receiving it.


Long press (of the same CEC command) is not supported with cec (at this time).
I know some Samsung remotes internally supports long press, which means they will send different CEC commands depending on how long you press the button.

The manual for the KS8000 suggests that this is also the case with your remote. Notably the return button witll act as exit when pressed for more than 1 second. For Kodi you will probably want to switch that around with a custom keymap so that long press will bring up the context menu.

If the internal IR of the Vero can be set to work with Apple Remotes or MCE, even XBONE and other devices, then you can use the IR function of your remote too control it. (treat the Vero as an Apple TV , MCE device, XBONE)

1 Like

Thanks @Soli…very useful info…

I did try “Long Press” the “Return” key and below is the output from the logs. It seems to be same case and when Source in VERO4K, TV not sending the “Return” long press to the VERO4K.

As per my note I can even use the Ch + / Ch 1 buttons for mapping as well and even they are not send by TV to the VERO4K and when tried TV displaying a banner saying “NOT Available”

11:17:25.765 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back
11:17:32.484 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back
11:17:35.468 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back
11:17:36.514 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back
11:17:41.645 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back
11:18:15.469 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back
11:18:19.200 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back
11:18:24.518 T:4111819696   DEBUG: OnKey: menu (0xd8) pressed, action is Back 

My VERO4K as is TV mounted at the back and I don’t think I can use the IR option you recommended…

If you got any more suggestions, I am more than happy to try out buddy… Appreciate your help on this taking your valuable time to help me.

Just in case link to manuel as below:

@sam_nazarko you are correct… From the TV manuel

      > **Using Anynet+ (HDMI-CEC)**
> **    Control the external devices connected via Anynet+ (HDMI-CEC) with the remote control.**
> **    You can use the TV's remote control to control external devices that are connected to the TV by an HDMI**
> **    cable and that support Anynet+ (HDMI-CEC). Note that you can only set up and operate Anynet+ (HDMICEC)**
> **    with the remote control.**
> **    Connecting an external device through Anynet+ and using their menus**
> **    Settings System Expert Settings Anynet+ (HDMI-CEC)**
> **    1. Set Anynet+ (HDMI-CEC) to On.**
> **    2. Connect an HDMI-CEC-compliant device to the TV.**
> **    3. Turn on the connected external device. The device is automatically connected to the TV. After**
> **    connection is finished, you can access the menu of the connected device on your TV screen using your**
> **    TV remote and control the device.**
> **    " The connecting process can take up to 2 minutes to complete.**
> **    Read before connecting an Anynet+ (HDMI-CEC) device**
> **    " You can configure the TV's Universal Remote to control third-party cable boxes, Blu-ray players, and home**
> **    theaters that do not support HDMI-CEC. For more information, refer to "Controlling External Devices with the**
> **    Samsung Smart Remote - Using the Universal Remote."**
> **    " Anynet+ cannot be used to control external devices that do not support HDMI-CEC.**
> **    " Anynet+ (HDMI-CEC)-enabled devices must be connected to the TV with an HDMI cable. Note that some HDMI**
> **    cables may not support Anynet+ (HDMI-CEC).**
> **    " The TV remote control may not work under certain circumstances. If this occurs, set up the device as an**
> **    Anynet+ (HDMI-CEC)-enabled device again.**
> **    " Anynet+ (HDMI-CEC) works only with external devices that support HDMI-CEC and only when those devices are**
> **    either in standby mode or turned on.**
> **    " Anynet+ (HDMI-CEC) can control up to 12 compliant external devices (up to 3 of the same type) except for**
> **    home theaters. Anynet+ (HDMI-CEC) can control only one home theater system.**
> **    " To listen to 5.1-channel audio from an external device, connect the device to the TV via an HDMI cable and**
> **    connect a 5.1 home theater system directly to the external device's digital audio output connector.**
> **    " If an external device has been set up for both Anynet+ and a universal remote control, the device can be**
> **    controlled only with the universal remote control.**

Your Vero 4K should have come with an IR extender that would allow you to use an IR remote.

It’s so sad that TV manufacturers won’t actually follow the CEC standard. I’ve had 3 TVs, and only one has (mostly) fully worked with CEC. A Vizio. I have a Sanyo, and while CEC works, it’s real limited (like the number buttons aren’t recognized) and I had a TCL that had a real limited remote like your Samsung seems to have. CEC was mainly unusable on it.

@bmillham Thanks for helping me on this adventure… I know this might be a NOOB question and don’t get angry at me… with IR solution can I use my TV remote to control the VERO4K and if so what are the steps I need to follow?

@Soli also mention about this but I don’t know how to do this and more than happy to give this a go…

@sniferx1 I was thinking about the FOXTEL (something I know nothing about). Sam mentioned that it’s using IR, so that’s why I suggested using the extender. Maybe you could use that remote? (And I understand why you may not want to. I LOVE having only one remote now that controls everything!)

My tip: Forget about CEC, get a USB cable extender, buy a FLIRC2 and set it to emulate a XBOX One. You should be able to tape it so that the sensor is still behind the display but right at the edge. The Flirc2 is really sensitive so it should work fine this way.

Maybe you will have to experiment with different devices to see which one works best with the buttons on the Samsung remote, and/or slightly fiddle with custom keymaps, and/or tweaking the Flirc configuration.

ps. The return button or other buttons might have long press functionality in IR mode and/or depending on the device it’s programmed to, which ironically you do not want since FLIRC2 supports long keypresses natively. Just a heads up of something you may have to work around.

edit: written before I read that there is a IR extender included. Maybe you could try that first…