Vero4k not handling symlinks?

I suppose if you really want to keep things as close to what you have now you could directory junction folders for individual shows to move them to another drive. To me this seems like a headache to keep track of but it would work.

It’s very easy to do but then I would have to continue using hardlinks and (as you can read above) it would clash with current TV dirs, I’d have to request an option that MIGHT be picked up from my recorder software to allow merging of directories on 2 different volumes.
With a RAID setup this wouldn’t be a problem, but with a normal setup it’s a huge issue.

I started hardlinking because symlinking wasn’t supported to stream way before the OSMC brand name came into place, I tried symlinking now and it still doesn’t work.

If @darwindesign knows a way to junction my files into the right directory (as symlinks or as a virtual folder that just ends up in the right place) I’d be fine with that as well!

Edit:
And one really odd thing about this is that I have made maual (with shell extension) symlinks from R: to T: and they play perfectly fine!

I don’t fully understand your setup, but I still think that just sharing the drive and a new source would work for you.

I have 7 drives. They all have Movies and TV Shows on them. They are mounted like:

/mnt/drive1/Movies
/mnt/drive2/Movies

etc. And they all are setup in Kodi as a separate source. When I add a new drive, I just add a new share and a new source. Nothing existing needs to be changed.

mklink /J Link Target [more info]

Say you have “The A-Team” folder taking up 80gb on your full drive. You can move that folder to another drive on that computer and then make a directory junction in the old location that points to the new location. Everything works local or network, no programs will know the difference. Rinse and repeat. This is basically what your doing now on a file instead of a folder level from what I understand from this thread.

What about merging a directory.
Say I have a TV show directory on M and on on T but I want the links to show up on T so it gets picked up by my entire setup so M:/TVShows would have to go into T:/TVShows as a soft link (no movement because it’s full).

AFAIK there is no mechanism for a folder that is both a link and a folder. You would have to insert a separate directory junction in T:\TVShows for every subfolder in M:\TVShows in order to affect what you want the way you want to do it.

lol then what can I say, this going to be a b*tchload (unnecessary since the whole problem is a file system not loading a link type) of work.

How could I still manage to get and merge (I could run an auto execute bat script every few hours moving things, no idea how but I could) M:TVshows with T:Shows?

My recorder client doesn’t have the option to add multiple directories (and aren’t planning to add it, I asked) to point at the same thing so if I could either have T:\Shows\Archer or M:\Shows\Archer, that clearly doesn’t work with 2 drives so they have to merge somehow but still be able to go into the same T:\Shows directory (I could symlink! oh wait no that doesn’t work with vero’s lol).
I honestly have no idea what to do with it.

OK I switched my PVR directory to point to the M dir (no cross drive linking anymore).

And it seems to work with symlink!

I don’t want to turn it on full blast yet until someone checks if I’m really doing it right.

This is an example and the file plays.

https://gist.github.com/DecipherIt/2d0ae3e20afb10c325f1da7a3c04e312#gistcomment-3475901

If you are okey with the softlinks on mac and windows and say that the Vero is the problem, why don’t you just use multiple shares and in kodi use multiple-paths in one source?

https://kodi.wiki/view/Adding_video_sources#Making_one_source_from_multiple_locations

Soft-links are for local computer(resolved to local paths) and have never been able to share them to network since they get the “other computers local path”, which on the client computer never resolves propperly.

Edit: I stand corrected, there are ways in a Windows enviroment to share symlinks, but you have to enable it in windows.

Read up, it actually works lol

I just need someone to verify that I did things right so I can turn on my PVR service again.

I know it works already but just to double check so it won’t screw up and give me a weeks worth of manual work.

Complain to Microsoft, not us.

Why would you have to do that? It sounds like your not quite getting what I was saying. If you currently have T:\Shows\Archer and you move that to M:\Shows\Archer and then you

mklink /J "T:\Shows\Archer" "M:\Shows\Archer"

Then you still have the same (apparent) “Archer” folder you had to start with except it no longer takes up any room on your T:\ drive. If you add a new file to T:\Shows\Archer it acts the same as it did before, and you don’t have to change anything else from any part of your setup. You can do this to as many, or few, folders you want to balance out your free space.

I’m not complaining to you guys, just the situation haha not your fault.

That would have actually worked, instead I just set my PVR to process things into M:/Shows when it finishes, Kodi just pics up on it then and sometimes I get double shows on my vero (like with Agents of shield) but that’s most likely because my initial version had a different ID and it changed over the years.

For now it all works good, I just had to manually edit my PVR client because it actively blocked symlinks because in the past it “destroyed directories” no idea how that happened though.

Actually, this is an issue with pretty much any OS and non-relative links, since symlinks are implemented as nothing more than a text string in the directory entry that points to the real file.
If you have a pure Linux environment, and nfs mount a remote share at /mnt/stuff, and there is a symlink inside there that refers to /export/shares/stuff/somefile, Linux is going to look on the local machine for that file. Even a relative link can fail, if it uses too many ../ to move up the tree out of the shared area.
I have gotten Windows symlinks working just fine using Kodi on OSMC as long as I use relative links and don’t pop out of the top of the share. For example, if you have an artwork file that needs to be named “moviename.jpg” for Kodi, but “folder.jpg” for some other software, you can symlink whichever way is easier, so that moviename.jpg -> ./folder.jpg, or vice-versa.

I seem to have gotten it to work - not well - but it works.
I know it’s not OSMC’s fault, it’s a windows issue, or a cross platform issue, it’s just a pain in the neck haha.
I’m on the latest OSMC (June? or July? release I think) and everything else is very stable.

@darwindesign
I had a lot of files not working on kodi, long load times (if loading at all) and buffer times, huge amounts of frame drops (up to 8 seconds) and failed scans. Then reading the logs I figured out that it’s most likely because I added the new device through kodi, and didn’t add it through autofs! So that’s most likely what causes the issues since I had similar behavior back before you explained to me how to set up autofs with HaneWin NFS (topic is somewhere above in this post).

I just don’t remember how I exactly had to set it up…
I’m sure I only need to add one line on every device and then do something(?) for kodi to find the mounted device again.

My export on hanewin is as followed
M:\TVshowz -name:TVshowz -readonly 192.168.1.114 192.168.1.116

I simply have no idea how to add it to my devices again. Could you help me out please?

If you have your other sources setup with autofs then all you would need to do to create another path is duplicate one of your other mounts in your auto.nfs.shares file and change the share and mount name. I’m sure you can figure that out by reading previous posts or referencing the autofs how-to. As for the Kodi side I would assume the best course would be to delete the source that uses the Kodi path and tell it to remove items from the library when asked. You can then add the source again but use your new mount point. Alternatively you can use path substitution which has a how-to written for it as well.

What is the path name to the autofs file I need to edit? Because I don’t remember it at all.

And what is the link to the tutorial?

Sorry I don’t do this every day so I’m unsure about some things!

/FFS

https://osmc.tv/wiki/general/mounting-network-shares-with-autofs-alternative-to-fstab/

So I’m thinking this is correct.

Added to my old settings in nano /etc/auto.nfs.shares

/mnt/Movie 192.168.1.110:/Movies
/mnt/Shows 192.168.1.110:/Shows
/mnt/Anime 192.168.1.110:/Anime
/mnt/Films 192.168.1.110:/Films
/mnt/TVshowz 192.168.1.110:/TVshowz

Only the bottom one was added.

on one device

 ls -lah /mnt/
total 12K
drwxr-xr-x  7 root root 4.0K Oct  8 23:41 .
drwxr-xr-x 23 root root 4.0K Dec  7  2018 ..
drwxr-xr-x  2 root root    0 Oct  8 23:41 Anime
drwxr-xr-x  2 root root    0 Oct  8 23:41 Films
drwxr-xr-x  2 root root    0 Oct  8 23:41 Movie
drwxr-xr-x  2 root root    0 Oct  8 23:41 Shows
drwxr-xr-x  1 osmc osmc 4.0K Oct  8 06:19 TVshowz

on the other

ls -lah /mnt/
total 24K
drwxr-xr-x 11 root root 4.0K Oct  8 23:43 .
drwxr-xr-x 23 root root 4.0K May 29  2018 ..
drwxr-xr-x  2 root root    0 Oct  8 23:43 Anime
drwxr-xr-x  2 root root    0 Oct  8 23:43 Films
drwxr-xr-x  2 root root    0 Oct  8 23:43 Movie
drwxr-xr-x  2 root root    0 Oct  8 23:43 Shows
drwxr-xr-x  2 root root    0 Oct  8 23:43 TVshowz
dr-xr-xr-x  3 root root 4.0K Apr 30 00:11 r:
dr-xr-xr-x  3 root root 4.0K Apr 30 00:11 t:
dr-xr-xr-x  3 root root 4.0K Apr 30 00:11 u:
dr-xr-xr-x  3 root root 4.0K Apr 30 00:11 v:

Strange.But it does seem like it added them, I think.

I left the path (TVshowz) exactly as it was as you can see in the config. Will it auto mount it replace or will I have to do some config changes because reading the guide I wouldn’t really know how to since they have the same name.

Edit: Seems like it’s working for now. I will have to test for a week or so to be sure it does.