Vero4K out-of-the-box issues


I’m a new Vero 4K user. I am currently in the process of setting it up, and coming across a few teething issues that i’m hoping I might be able to get some help in debugging/figuring out a solution. The first thing I did after connecting to the TV was do an update so i’m on the latest of everything.

(As an aside, one concern I have is that I’m seeing VERY poor performance (and not bottlenecked by the network, which has a good 100mbit connection to my NAS, but is using around 1500kbps-2000kbps) when streaming clips like the LG Chess HDR sample. I’ve seen this comment so will save judgement on that for the moment, though I am also seeing very choppy (unwatchable) performance on a 30GB 4k 110minute file which may or may not be related.)

  1. HDMI CEC not working.
    – It worked for a minute or so when it was first turned on, and hasn’t worked again since.
    – I’ve tried using both the supplied cable, and another cable and TV input that I know works.
    – cec-client is outputting messages that suggest it is receiving the events ok (i.e. writing key press down when i press down on the TV remote).
    – TV is a Samsung US55KS7000, connected directly to the Vero 4k.

  2. Automatic resolution switching
    – Is this supposed to work? I seem to recall seeing it on here somewhere, though I can’t find it now. The UI is too laggy to use if I leave the resolution at 2160p, so I prefer 1080p for more fluid UI animations, but if I play a 2160p video, it’s being downsampled to 1080p.

If anyone can help point me in the right direction for some of these, that would be much appreciated! Maybe I’m just not quite used to some of the more expert config settings. Hoping it’ll turn out to be a nice piece of kit once it’s all set up right!


Hi Alex,

We have optimisations in the pipeline to improve playback of higher bitrate content. In February when we settled on the current scheme for Krypton for the initial release, we did a lot of real world testing. We decided that while we could improve performance for some very high bitrate clips, it would delay video startup time by a significant amount for all clips. Fortunately we should be able to achieve a better compromise in the next update.

This is more interesting than playback of samples. Although we’re well aware that sample clips are commonly used to evaluate devices, we’re not particularly interested in optimising Vero 4K for them. We’d prefer snappier loading times for real world scenarios. So if you have an actual clip that’s problematic, that’s good to know. I’d also like to know how you ripped the file and MediaInfo summary.

Are you running the latest version of OSMC?

Yes, it’s supposed to, and does work (tested on a few 4K TVs).
Do you have Adjust Refresh Rate enabled?

Also worth posting a debug log when your device is running the latest version. OSMC will only switch mode to 2160p if the TV advertises 2160p as the preferred mode in its EDID. This can certainly be changed, but we don’t change modes unless we’re confident that it’s the right thing to do

I’m confident we’ll have this working as expected for you with a bit more information from your side.



Thanks Sam!

The 4k video is ok today, actually. I’m guessing a reboot solved it for whatever reason.

I didn’t, and that fixed it. Thanks! As a suggestion, would it be worth enabling that by default?

I did an update as my first step when setting up. I’m on OSMC May 2017 2017.05-2.
I did another test today and it appears sometimes keypresses are registered from kodi and sometimes they are not. They do appear in the logs but don’t do anything in kodi. In this test, I booted the vero and pressed the down key on my TV remote 5 times. It seems like cec-client only picked it up twice (if i’m reading the logs correctly, though it’s entirely possible that that’s not true). The cursor did not move down at all in kodi during the test.

Debug logs from kodi during this test:
cec-client.log during this test: cec-client.log · GitHub

Thanks for the help!

Hi Alex,[quote=“Alex_Chilcott, post:3, topic:37474”]
I didn’t, and that fixed it. Thanks! As a suggestion, would it be worth enabling that by default?

It depends. Some people get a bit confused with the black screen as the refresh rate is adjusted, and some people don’t have 24p capable sets.

For now we leave it off by default. We tried having it on by default on Raspberry Pi a while back but this confused some users.

It’s probably best to stop Kodi when you are testing with cec-client.

A few recommendations:

Also, if you have a Pi, can you test on the same TV + HDMI cable? We made some CEC changes in the May update. They’ve improved things for some users but not for everyone. The joys of CEC…

Cheers Sam,

I have tried with multiple HDMI cables including one that used to be connected to a FireTV 4k which worked with CEC, so do not believe this to be an HDMI issue.

I did find though that kodi at least reliably logs CEC key presses when my Yamaha soundbar is turned off. I updated the device_type to 4 as recommended in the other thread, and that seems to stop the soundbar from preventing kodi from seeing the CEC key presses, but it still wasn’t responding to them. As an aside, is there any documentation on the change above? I’d like to know exactly what’s going on here (as much as someone who’s not intimately familiar with the internals of Kodi or CEC can, anyway).

Anyway, I then accidentally nudged the channel up button on my remote, which kicked the tv off the Vero input and onto live TV. Upon returning back to the Vero, CEC had inexplicably started working… This seems to be reproducable. If I turn everything (TV, amp, vero, etc) off at the power socket, then power it all back up, CEC doesn’t work on the Vero until I bump the channel up/down button on my remote once!

No idea quite whats going on here, but it seems to work ok for the time being, so long as I don’t breathe on it too hard.

Cheers for the help!