Vero4k Vero4k+ BURNT OUT

I have the original Vero4k and Verok4k+ and to be honest I am done. I have tried every setting on the planet but these boxes are just buggy. I can play ANY file on my pc and they play flawless. I have been chasing the slight video pause on both units for over a year and NO setting will every fix it. All my media is stored on UNRAID so I am not sure that is the issue but if the PC can play it flawless the Vero should behave no different. I have been running different variants of Kodi/XBMC all the way back to the XBOX days so I have been around for awhile. I have better luck playing 4K videos from an RPI4 it seems. I really like the size of the hardware but I am just exhausted trying to get these to behave like vlc does. :frowning: Edit All my boxes are IP controlled via Control4 and the Chowmain driver.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Will do thanks!


I’m sorry to hear this and happy to take a call to discuss things.

I assume things must’ve worked at some point if you had a Vero 4K and then moved to a 4K +. Let’s backtrack from there.

Can you try with a fresh install without Control4 etc and see if things behave as expected? We can then build up from there until your solution is complet

I’d like to get things working for you promptly and I’m confident we can do so.



I am running the original vero4k in my master (LG43HDR) and the Vero4k+ is in my living room (65OLED)

Please post some logs as advised

We need to see more than just the Kodi log. Please post full logs.

Does this work?

That’s better. You don’t have Adjust Refresh Rate set to start/stop. This will cause the problem that you’ve described.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

I have tried enabling (Adjust display refresh rate: On start/stop on numerous occasions and the slight video pause is still there as well as every other possible setting.

I may copy media to a USB drive and see if its a network issue. I produced the same result from a windows share and from my unraid server. I run all Luxul network gear.

Copy the file to the eMMC for the best test case scenario.

We should also ideally agree on a test clip. Something like Big Buck Bunny usually works well


After fighting this issue forever and spending countless hours I fixed my issue. ODROID N2

Hi Tony,

My understanding is that your purchase was via an AV company that you work for.

I was a little perplexed by this post and the sensationalist headline to begin with. We are always happy to help and get things working for our users.

After checking things, I can see that you were interested in stocking the Vero 4K +, but the price didn’t meet your expectations.

I’ll lock this post now but my offer stands as before, happy to talk about this over the phone. I’m sure that you can appreciate that our reseller pricing is commercially sensitive and as such we are not keen to discuss it on this forum.

Of course if you prefer to re-sell the Odroid-N2 that’s fine, but I’m sure users here would appreciate the disclosure that you are a reseller and your opinion may somewhat be influenced by this.

Your device doesn’t seem to be burned out, and we are happy to resolve any issues you have. You can either start a new post with logs or open a support request.