Vero4k Video playback aborting since update to 2017.12-1

It’s not actually. You are confusing megabytes MB and megabits Mb. :slight_smile:
8539kb/s = 8.5Mb/s = 1.06MB/s which is still much less than ~5MB/s I got using the Kodi Filemanager…

Use wired only

1 Like

You are right, didn’t consider the lower case “b” in Mediainfo.
So than I am out of ideas why it fails playing back via SMB but is fine when playing locally

@neoacix: In the logs all the time the VideoInfoScanner is running, also while you start your video.
Looks like the you have enabled

Settings -> Media -> Library -> Video Library -> Update Video Library on Startup … or so.

  • Could try to reproduce your issue when this update process has finished or deactivate this feature and reboot?
  • Does this make any difference in behaviour?
  • BTW. what Synology is it running what DSM version?
  • Have you checked the Syno logs for any errors?
  • If you use another player for the same problem video via smb like VLC on Windows, do you get another behaviour?

Sorry, I was a bit impatient to start the reproduction. But not all attempts are obscured by the update process, as far as I can tell.
Can I ask you to check again the timeframes starting from 21:04:58.328 (this episode plays fine) and 21:05:22.090 (this episode aborts)?
If you need to see the Kodi startup itself, where the scanner and library updates usually run, I can repro with the offending options disabled tonight.

I observe the issue also after all library updates are completed, with OSMC/Kodi running in idle for hours.

DS1515+ running on latest DSM 6.1.4-15217 Update 5

Will check tonight, but I do not expect to find anything

Works like a charm on other devices (MPC HC on Windows)

Well, one idea I have is that related smb version (and a possible bug) has to do with it.
My Vero 4k tells me that it uses max. SMBv3, my Syno has max SMBv1 but I’m not sure whether this is the default.

@neoacix: So, what are the settings on your Vero 4k and your Syno?

1 Like

DSM is configured for min. version SMB1 and max. version SMB2.
I enabled debug logging and watched log.smbd while attempting to start mentioned Stargate episode. I can’t really make a lot of sense of the o/p, therefore attaching it here in case anyone wants to take a stab at it.

Interestingly, when I set the max. version to SMB3 rather than v2, the issue appears to be no more. Video files previously failing to play after the December update now run fine. Or at least the two that I tried do.
When setting max. version back to SMB2, the same files immediately refuse to play again.
So I assume that some Samba update has been included for the OSMC December update, that is affecting SMB2 behavior; Can somebody confirm?

Thanks,
Michael

Samba debug log of starting a video file under
SMB2: http://paste.osmc.tv/uxuqagariw.md
SMB3: http://paste.osmc.tv/oyekoxuveb.md

3 Likes

At least you have a solution setting max. SMB to v3 on the Syno, now. I tried your problem smb constellation also with a Syno DS214se but this got also DSM 6.1.4-15217 Update 5 till now … but I cannot reproduce this.

Can confirm.

Did the December Update on my Vero4K and got Problems with streaming Files from my Synology SMB Shares.

Some files did not start at all.
Some files we’re starting and when i skipped 30 Seconds or more, i we’re sent back to menue.
Some files looked like they we’re starting. You could see the Playbacktime in the upper right Corner, but nothing happens.

Before the December Update Stream Files from my Synology SMB Shares we’re no Problem at all.

My Vero ist hooked Up with an Ethernet cable.
Updated my Synology to the latest Firmware.

@vero4knoob: And have you tried to set the max. Smb version to smb3 on the Synology?

Yes, i did.
Thx to neoacix!

Then it works again, with all files i tested so far.

But i don’t know, what the default SMB setting in Synology is, so this could be a problem for some people…

1 Like

It’s actually thanks to @JimKnopf, he sort of pointed the direction and led me exploring the depths of Synology Samba configuration :smiley:

This seems to work for now, so I want to thank all who helped get there!
If you need any information or log that may help you fix the SMB2 issue, just give a holler… :slight_smile:

1 Like

Then a big THX to @JimKnopf too. :smiley:

1 Like

Hi folks, give @neoacix all likes you can. He has had the most time investment and made the final prove. :+1:

Hi guys,

I’m glad you’ve resolved this. There haven’t been changes to Kodi’s SMB implementation, but Debian Stretch does feature newer versions of Samba packages. It looks like this may be one to keep an eye out on.

I’ve written to the Debian mailing list some time ago about some problems with the current Debian Samba implementation but we didn’t get far with this.

We will monitor the state of Samba in Debian. If there are long term problems and it doesn’t meet the requirements of OSMC, we’ll package this and include it downstream with some improvements.

Cheers

Sam

Ok, just did some new tests and finally was able to reproduce this also on the Synology DS214SE (which is one of the smallest Synology’s ARM platforms) after using very small video trailers. All AC3 trailers let abort the stream for the videoplayer at once, some of the TrueHD and DTS trailer as well but I don’t think it’s that related but more the size of the clips.

The required condition for this issue is

  • Vero 4k: Settings -> Services -> SMB client -> maximum protocol version = SMBv2 or SMBv3
  • Synology: Control Panel -> File Services -> SMB -> Advanced Settings -> Maximum SMB Protocol = SMB2

What me very wonders is that the combination

  • Vero 4k: max. protocol ver. SMB2
  • Syno: max, protocol ver. SMB3

works … ??? I expect the negotiated protocol version is then SMB2 but this constellation does not show the error.

So, setting both sides to SMBv3 or forcing the Vero 4k to SMBv1 solves this issue.

1 Like

Thanks for letting me know. I wonder if we should change the default setting from MAX to SMBv3.

Sam

I think you miss understand. Kodi is on max SMB 3 .
This is about people changing the settings on their NAS

I found it on my OSMC devices set to SMBv3, isn’t it the default already?

On the Synology NAS there seems to be a lot of users with a setting of max. SMBv2 … which is causing the issue. Without deeper knowledge it seems to be an issue with SMBv2 … but I do not get a clue out of it why Vero 4k with max. SMBv2 and Syno with max. SMBv3 works here.

Yes – but the problem is that Max is meant to automatically decide. It needs a patch in Samba for this to work however.

So it makes sense to change the default guisetting possibly.

Vero 4K December update

Buffalo LinkStation LS210D latelt firmware 1.66-0.01, in the settings it says Protocol SMB2: On
http://www.buffalotech.com/products/linkstation-200-series

I switched in Kodi Max protocol version from SMBv3 to SMBv2 and still have the same problem with a file aborting after < 10 sec of playing or so.

the log:
https://0bin.link/paste/keyFc1km#oMtELat0mgRX3xsr9cvFqXd0Gl2jjjNU4qpj+JxxY4q

the file plays OK from USB