Video Calibration

I must have gone blind as I can’t find the setting in the new Kodi/Estuary/OSMC?

Nope its still there been using it on Kodi 18 even :slight_smile:

I’d appreciate a clue!

Same problem here on the Vero2. updated to Kodi 17 yesterday and Calibration is missing, or rather the option to calibrate the screen is missing from the calibration settings. It now just has an option about the number of buffers to use (?).
My workaround for now was to change the zoom property for the user interface so it fits the screen and then when playing a video to change the zoom value on the video options menu and make that a default for all media. Total fudge though.

Th odd thing is in Settings>>Display it says it is “windowed” and is greyed out so can’t be changed to full screen (even thought it appears full screen). I suspect the video calibration option doesn’t appear when display is set to windowed.

have you enabled “Expert” mode ?
it is available in Kodi official skin

I don’t want to hijack this as I know it was opened up under Rpi2 and I use a Vero2, but my settings are on Advanced mode and still no Video calibration option. I have tried the OSMC skin, The official Kodi skin and confluence. All the same problem.

I think, at least for the Vero2, that the problem is the latest version of OSMC is set up as “windowed” mode rather than full screen and I don’t think this allows for calibration (this makes sense as running Kodi in a window wouldn’t result in any overscan).

As a matter of interest, is your set up showing windowed or full screen?

It looks like you have to change the skin to the official Kodi skin (or Confluence), enable expert, recalibrate the screen and then restore Estuary.
Alternatively a developer could enable video calibration in the Estuary skin for a future OSMC update - maybe :slight_smile:


3 posts were split to a new topic: Off topic crap

Pressing left on a settings screen was what I needed to know.
I can then select Expert and get access to video calibration.
However, (using OSMC skin) I do not see any arrows or the square rectangle, but I do see the subtitle bar.
I have now set up my LG tv successfully so this minor problem is solved.

I have some problem with video calibration, but something little different.

Everythnig was fine with “old” OSMC version but with the new one based on the latest Kodi, something weird happen…

I use Raspberry 3 on a Samsung TV.
I found the video calibration menu thanks to your posts guys…
I correctly set the calibration, everything seems fine in the OSMC interface…

But when playing a media (Movie ou TV series), when I press pause for exemple the OSD that appear is partially out of my screen, up, right, bottom and left…
I try to reduce the image size in the video calibration menu, no effect on the osd when playing something…
Seems that video calibration don’t apply when viewing something…

Is someone getting that strange thing ?

Thanks a lot !

PS : OSMC is really great ! :slight_smile:

Very strange…

Just after I send my previous post, I notice that even in the OSMC menu my video calibration was gone just after playing a file.

So I decide recalibrate, again, and got a calibration screen with out the corner… More specificly the corner was far far out of the screen view, by pressing left and down I was able to see the calibration corner, after this final recalibration, everything is fine, osmc menus, tv series osd…

It’s working…


Sorry for the noise… :slight_smile:

It seems you’ve sorted your issue out, but also if the actual TV has overscan turned on, turn it off and that should sort out the OSD not fully being visible.