Video playlists showing “Path not found or invalid”

I’m not sure how it happened, but probably when I was trying to delete a duplicate “Concerts” playlist. Now when I click on “Videos-> Playlists” it just gives the “Path not found” message and I have to click OK.

That’s the main issue above, but for additional context:

I’d like to fix that, and I still have the duplicate showing when I click on “Concerts” from my main page. it shows two playlists (at least they have the playlist icon) titled “Concerts”. When I click on one of them it shows my concert videos.

1 Like

That is good to know, but I think all I really need to know is where Vero is looking for the playlists when I click on “Videos -> Playlists” from the UI. I’m guessing it’s looking here:

Is that correct? If so, I have that file, and it only has this in it:

<?xml version='1.0' encoding='UTF-8'?>
<node order="60" type="filter">

So shouldn’t that be good? What am I missing?


hmm. Yes, I see that, but what about the node playlist as you mentioned in this post:

That also creates a playlist, does it not? And a new node.

I showed two different methods in that thread to do the same thing. The one using a playlist you have to make a playlist (which was the picture I posted there) and that would automatically get saved in the folder structure I posted above. Once you have the playlist you would then modify the skin to add a menu item that linked to that already created playlist. Perhaps you did this and then deleted your playlist thereby creating a dead link in your UI?

Yes, I think that’s what it was. As mentioned, I somehow got a duplicate “Concerts” playlist from the main page. i.e., The main page has a “Concerts” node. I click on that and I see two “Concerts” playlists. One is empty, and one contains my actual concerts. And I can’t seem to figure out how to delete one of them. Actually - I don’t think they are the kind of nodes I want. I want an actual Node - not one that looks like a playlist.

Do you have any idea how to remedy this? I don’t have a backup prior to the corruption. I guess I could restore from scratch, but I’ve done alot of custimation.

Your using the OSMC skin right? It should just be a matter of going to settings>interface>skin>configure skin>general>customize home menu> (note that this is where you would have added the new menu items in the first place) on the left highlight the menu item you want to remove, then move to the right side and select delete. If things have gotten really messed up then there is a “restore menu items” option at the bottom of the screen and that should reset your menus to stock so you can start from scratch.

Edit: There is a “restore menu items” option at the bottom of the screen and that resets the current menu item to default. To bring all the home menu items back to stock then you can go to settings>interface>skin>configure skin>backup/reset>reset all home menu items.

1 Like

Appreciate the help, but still no luck. I did the reset (it’s actually “reset all menu items”, not “reset all home menu items”), but that didn’t prevent the “Path not found or invalid” error when I go to “Videos->Playlists”, nor does it git rid of the duplicate “Concerts” from appearing in the “Concerts” node (after I create an initial “Concerts” using the step you mentioned above).

I don’t know if the two problems are related.

I can live with the “Path not found or invalid” in Videos->Playlists, but I don’t like the duplicate “Concerts”. Moreover, I don’t like it showing like a playlist - I want to just click on “Concerts” and bring up the concerts, just like clicking on “Movies” brings up the Movie listing.

fwiw, I did a find under “.kodi” for the ghost playlist and this is what I got:
osmc@KevinsMedia:~/.kodi$ find . -name “playlist*”

When you go to videos>playlists there is nothing there, not even the partymode playlist?

There is an bug that afaik still exists (I didn’t retest) with using nodes to pull from a file path. See this thread…

EDIT: I checked, the bug is still there.

1 Like

The playlist method is much easier (I just tried it again) but if you really don’t want to go that way here is a convoluted path to what you want. Bear in mind that I don’t know what i’m doing. I just play around until I find something that works.

The first thing your going to need to do is change your skin to Estuary temporarily. Go into the movie section and you should see a double dot .. at the top of the list. Click on the dots and in the menu it takes you to go to the slideout menu and select “Edit nodes”. Note that even though this brings up the Library Node Editor add-on it for some reason is different than opening the add-on directly, and why we needed to switch to Estuary.

The first thing we are going to do is hide the concerts from the movie node. Click on “Movies >” then “Titles” then click “add rule” and change the rule to path>does not contain>(path to your source). Now navigate back a couple times so your back to the first screen when you entered the node editor where it shows your main menu items.

We are now going to add a node for the concerts by clicking on “new node”, give it a name and click OK. Next you will click on the node>add content>movies. Click “add rule” and change the rule to path>contains>(path to your source). You can also add sorting here if you wish. You should now be done here so you can just keep backing out until your back on the home screen.

To make sure everything is working go back into the movie library, click on the double dots .. and on that screen click on the double dots again. You should now see your new node so click on that and verify it is working. In that same screen you can also go to movies>titles>and your media from your concerts share should not be there. If everything is working as expected change your skin back to OSMC Skin.

Go to settings>interface>skin>configure skin>general>customize home menu> To change the movie shortcut to the node that hides the concerts with “Movies” selected on the left click on “change action” on the right and navigate to videos>movies>titles>

To add the new menu item click on “add” at the bottom of the screen. Click “enter title” and give it a name. Click “change action” and navigate to videos>(your node name). If you now navigate left you will see next to your new menu item up and down direction pointers. You can click on these to choose the order in which this new menu shows up.

If your wondering why you had to switch to Estuary to edit the nodes instead of having access in the OSMC Skin that would be a @Chillbo question :grin:

Regarding the “Videos->Playlists” issue, the solution you mentioned was:
“A solution that seems to work the way you want it to may be to go to Videos>playlists>new smart playlist”

However, I don’t understand how this is supposed to work? As soon as I click on “playlists”, I get the “Path not found or invalid” error.

See screenshots.

So then I thought I’d try the the approach you detailed with the Node Editor, but the first step is changing the skin to Estuary. I know I tried that skin before, so it used to work, but now I get an error when I try to change skins to Estuary (see attached).

So I’m guessing I need to try uninstalling and re-installing Estuary?

I’m thinking that somehow the party mode playlist may have gotten corrupted or deleted somehow and that is what is producing the error. If you want to post some debug logs it might show some clue as to what is going on. Does the playlist error only happen in the OSMC Skin or does it do the same in Estuary as well?

No, that is a known bug. You can ignore the error and a reboot brings that skin back to looking as it should.

OK I rebooted and immediatly changed the skin to Estuary. At first a sad face (system error) came up, but the Estuary displayed correctly. I went to Videos -> Playlists, and yes, I got the same “Path not found or invalid” error.

I’m not sure what has gone wrong with the playlists, or how to fix it short of dumping your userdata, but if it was just something with your manual edits of nodes I would probably just try deleting everything in ~/.kodi/userdata/library/and reboot Kodi and see if that fixes it. If you had already followed my guide then this will have to be done again as that is what creates these custom nodes.

OK I ran the Debug. I tried to upload the whole log, but it was too big, so I’m just pasting a sub-set. What is the best way to share log files, btw?

I think that’s where the problem is… probably something I did. I’ve been playing around with it for a while and must have messed up something.

2020-05-29 10:29:49.904 T:4066656256   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
2020-05-29 10:29:49.905 T:4066656256   DEBUG: HandleKey: return (0xf00d) pressed, action is Select
2020-05-29 10:29:49.908 T:4066656256   DEBUG: CGUIMediaWindow::GetDirectory (library://video/playlists.xml/)
2020-05-29 10:29:49.908 T:4066656256   DEBUG:   ParentPath = []
2020-05-29 10:29:49.910 T:3694502624   DEBUG: Thread waiting start, auto delete: false
2020-05-29 10:29:49.914 T:3694502624   ERROR: <content> tag must not be empty for type="filter" node 'special://masterprofile/library/video/playlists.xml'
2020-05-29 10:29:49.914 T:3694502624   ERROR: GetDirectory - Error getting library://video/playlists.xml/
2020-05-29 10:29:49.914 T:3694502624   DEBUG: Thread waiting 3694502624 terminating
2020-05-29 10:29:49.916 T:4066656256   ERROR: CGUIMediaWindow::GetDirectory(library://video/playlists.xml/) failed
2020-05-29 10:29:49.916 T:4066656256   DEBUG: CGUIMediaWindow::GetDirectory ()
2020-05-29 10:29:49.916 T:4066656256   DEBUG:   ParentPath = []
2020-05-29 10:29:49.932 T:3694502624   DEBUG: Thread waiting start, auto delete: false

And this is the content of that “playlists.xml” file:

<?xml version='1.0' encoding='UTF-8'?>
<node order="60" type="filter">

So - can I just delete the playlists.xml file from the command line?

I would delete everything in the ~/.kodi/userdata/library/ folder and reboot. This will make sure all the nodes go back to default so you can start with a clean slate. That folder is empty by default.

There is an obvious error with your edit. The default would be something like this…

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<node order="21" type="folder">

Deleting the userdata/library content got my playlists showing correctly again. Then doing the old duplicate playlists fix mentioned previously got me working exactly as I wanted. No need for the “nodes” approach.

Thanks again!

1 Like

I’m glad you got it going. I think for most people the playlist approach is the more ideal path as it is much easier to understand and get it right the first time. I think you probably already get this but just for anyone else reading the thread that may get confused the approach that results in duplicates is only when you point to a file share from the OSMC Skin’s UI setting as there is a bug in some third party software that the developer didn’t want to fix. The convoluted way I posted above gives the exact same results as the playlist method, no duplicates, just without the playlist.