Video slow, audio ok

several files like this, where the vero4k is playing slowly the video, while the sound is ok
usually it is webrip of some series - any help?
Thank you!

Hi Marek,

Can you upload some logs via My OSMC so we can check your settings?

It looks like you’ve uploaded the entire episode of this program.
For legal reasons this isn’t allowed on our forum, so I’ve removed the link.

Is it possible to upload a sample file instead?

Hello Sam,
ahh sorry - makes sense - my apologies - hmm not sure I can provide a sample of a episode - any hint how to cut the part of the file on mac w/o losing its codec and sound settings ? logs here
I have seen this several times - tried to play the file on mac with movist app and it works just fine
Or I can provide the test link on e-mail not here in the forum

Thanks for help!

Your link doesn’t work (I fixed the typo for you where you had httos instead of https), Please double check the link.

Hello here is what I have done now
played the file from stream and stopped, then I have uploaded the logs again
Thank you

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Hello @fzinken,
thanks for the resolution hint - this really helps with response time of the kodi UI!
yet it had no effect to video x sound issue.
Thank you.

Adjust display refresh rate: Off

This should be set to On Start/stop. That will probably solve the audio problem.

Regarding your video issue, check some settings you find at

GUI Settings->Player->Video

There activateAdjust Display Refresh Rate” and deactivateSync Playback to Display”. The latter prevents audio pass-through modes in general.

bingo - Adjust Display Refresh Rate helps! THANKS!
My sony shows the source name for a while, which is a bit anoying but it worsk just fine!
I will not go for no pass-through - this is the reason I have got vero4k to have home cinema sound :slight_smile:
Thanks - we can close the topic as solved :slight_smile:

Yea, that’s the only downside to using that setting. But it’s worth it for the overall improvement that it gives. Glad it worked for you!

Thanks for quick solution hint!!!