Video stops after several minutes


I’m having a problem with some videos in my library, they suddenly stops playing(for example after 8 minutes into the movie “Spotlight”) and hit me right back in the main menu.

And i’ve tried playing the video from my computer, and that works just fine, so the files can’t be corrupt. I dont have this problem with all movies, just some of them.

Have tried rebooting all devices and change some resolutions and freq to lower but that didn’t work.
My connection is wired .

The movies are stored on my NAS.

I’ve uploaded the log here:

Thanks for support guys,

Network problem?
2019-09-15 21:13:58.891 T:1259320032 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

Can you try to play the file from the SD Card or a USB Stick?

Some people using a NAS are finding they are more reliable when mounted to the system rather than through Kodi. I would recommend creating a system mount for one of your shares and then use the file manager (in settings) to play a file from this new mount. If this fixes the issue then I would recommend adding system mounts for all of your paths and use a path substitution to automatically redirect your paths without having to modify anything in your library.

Just a thought, are you seeing the ‘lightning’ symbol in the top right corner of the screen indicating an under-power situation? For some reason similar started happening to me prior to the last update.

1 Like

Yes I do. Any thoughts why?

Your power supply is not providing enough voltage, or your cable is unable to maintain it.

You might also want to try removing force_turbo as running a CPU hot makes it draw more current.

The user could also just buy the power supply from the OSMC Store, which will fix the problem.

Sorry for delayed reply.

I can’t really offer an explanation as to why it happened. I just started noticing the low power symbol particularly when searching for titles and sometimes downloads would abort and I’d get the odd freeze, crash and reboot.

I don’t believe it had anything to do with hardware as the problem rectified itself after a clean install using OSMC_TGT_rbp2_20190522.img.gz, so the only thing I did was remove and replace the sd card.

You were running it overclocked. When you started over you removed the overclock.

I’ve had this rpi2b almost 5yrs, never run it overclocked and have always used default settings for OSMC. The only thing that might be attributed, I suppose, is the environmental factor as I don’t use heat-sinks or cooling fan and it was occurring around the time of our unusually warm summer, so it just might have been coincidence that updating OSMC seemed to instantly fix it - but definitely not overclocked.

Reading through the posts in the thread I guess there might be a mix up with yourself and actually @mrjackeb who seemed to had turbo.
Anyhow another clarification lightning symbol is a power supply or cable issue not a overheating issue

It was just that this comment by @darwindesign

You might also want to try removing force_turbo as running a CPU hot makes it draw more current.

… made me think that the hot weather could have been a factor, but then, I’m probably misunderstanding the phrase ‘running a CPU hot:thinking:

So I guess some clarifications are in order. First the symbol in question is exclusively about a voltage check. Second is that if your system is running but showing that symbol then you are sitting very close to minimum voltage for the board to stay running. For most people this simply means that they are not using a good enough power supply and it should be replaced.

As for the previous comment on the overclock and running hot. I mean ‘hot’ in the literal sense. Every CPU draws more current when it is hot then when it is cold. When you use ‘force turbo’ you not only push the CPU to stay at its maximum power drawing state, but this increases the temperature above where it would normally sit at which further increases power draw without an adequate cooling solution. Ambient temperature can actually factor into this but you normally would have to have some really bad circumstances and somehow not be triggering the over temp throttle (again, force turbo).

This extra current draw is only playing a factor if you are running on the edge of what your power supply and the cables connecting it to the pi can handle without a significant voltage drop. If you take the same system and put a good PSU on then the problem will likely go away. You take the same system and lower the power demand (underclock) and the problem will likely go away.

Bought the power cable from OSMC shop but the problem is still there… and other thoughts?

Which problem exactly? The underpower warning (lighting symbol)?

Has it always been a problem from new, or is it a recent development - maybe a poor solder joint between board and micro usb socket?

If the power cable has been frequently disconnected/reconnected, perhaps using a contact cleaning spray in the socket could help?

Have you tried updating OSMC if not already on the latest? Worked for me but could just be coincidence.

Do you know anyone with a good working setup who would allow you to swap-out their board into your setup to see if it persists?

Otherwise I’m at a loss.

Afterthought: Forgive my ignorance regarding NAS devices - does yours connect via usb? Does it require connecting via a powered usb hub?