Video stuttering & no sound


Problem solved

Please look below if you have the same issue.
The solution is to turn off “Group Key Rotation” in your Wifi Router.
I discovered the message

wpa_supplicant[323]: wlan0: WPA: Group rekeying completed

in journalctl

And after this message occurs everything went slow. It does not play a role if you use an internal or external Wifi device.
Iperf3 seems to give false readings.

This is no config issue with my router. Turning Group Key Rotation off ist not very funny. This is standard in WPA2 and not other device has a problem with it.


What happend?
If I start an *.mkv file from my NAS the movie starts stuttering and sound is muted.
This behaviour does not stop at any time.

Media Info

I switched debug on and restarted the Pi 3 and reproduces the problem. The problem starts at ~15:03:49 until the end of the log

CPU is at 100%

I guess the interesting path is this:
15:04:50 285.137512 T:1487922160 NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
15:04:50 285.169586 T:1956283312 NOTICE: Previous line repeats 7 times.

I used Notepad++ to count the occurences of “OutputPacket skipping a packets” and the result was 4457.

Can you try with a Krypton build?

Is this the best way to get it?

I’d start here: [TESTING] Kodi 17 (Krypton) Beta Builds for all platforms

Done but the problem remains.

Debug Log
Problem occurs at ~12:40

12:40:11.077 T:1760023536 DEBUG: script.module.osmcsetting.updates : - blurp 504 - VideoFullScreen.xml
12:40:17.762 T:1929376752 DEBUG: ActiveAE::SyncStream - average error -366.105459 above threshold of 100.000000
12:40:18.065 T:1929376752 DEBUG: ActiveAE::SyncStream - average error -16.105459 below threshold of 30.000000
12:40:19.160 T:1929376752 DEBUG: ActiveAE::SyncStream - average error -1804.160193 above threshold of 100.000000
12:40:22.466 T:1929376752 DEBUG: ActiveAE::SyncStream - average error -4.160193 below threshold of 30.000000
12:40:23.501 T:1929376752 DEBUG: ActiveAE::SyncStream - average error -3804.163338 above threshold of 100.000000
12:40:30.493 T:1502606320 DEBUG: CMMALVideo::SetDropState - bDrop(1)
12:40:30.495 T:1502606320 DEBUG: CMMALVideo::SetDropState - bDrop(0)
12:40:30.572 T:1502606320 DEBUG: OutputPicture - dropped in output
12:40:31.089 T:1502606320 DEBUG: CMMALVideo::SetDropState - bDrop(1)

FPS is only at 7

Can you copy the file to the pi (sdcard or USB stick) and confirm if the file plays okay?
Would like to know if this is an issue with the file, or an issue with network/nas.

Just testing: no issues if using an USB stick

Are you using wired or wireless?
What is the NAS? Can you try with nfs?

I am using wireless and have issues with it.
Its a QNAP Nas but it does not play a role if i use the NAS or download a file from the internet. Speed is identical.
I guess NFS will have the same problems if its a network issue.
I fought this has nothing to do with my network because the normal behavior of kodi is to stop playback and fill the buffer.

Should I still try it with NFS?

NFS is worth a try.
I’d also suggest trying with an ethernet cable just to be sure if it is a wifi issue.

I already figured out that NFS is slow too:

iperf is fast end every other protocol is slow…
It would be really nice to get some help here.

Whoever can help me solving this issue gets a 12 month censored account… I am desperated

Problem solved, look at first posting.
Not a good behavior here how to treat users. Asking me to do a lot of things which costs a lot of time and when stop answering after I did everything you asked me. I guess this is a general bug but I will not open up a bug report. My bug report I tried to open has been closed.

And all other devices do not have a problem with the router so it’s not an issue in my network

The problem, if I understand, was a configuration issue with your router.

It was suggested several times that the behaviour was not widespread and was likely environmental.

The burden of proof is on you to prove there is a bug in OSMC. You were asked to provide information to see if there was an issue with OSMC, but we did not find anything from it.

Before making smug comments, you should remember that people were trying to help you in their own free time. They have no obligation to do this. It took time for you to provide logs but we also spend time on OSMC and helping users.

The fact that you found the issue to be a problem with your router suggests that you did not investigate whether the problem was localised before taking the forum to denounce it as a widespread bug and post in multiple parts of the forum.