VPN add-on for OSMC

Does anyone know if there is a VPN add-on for OSMC? I have looked at Datho, but they say this only works on XBMC/KODI!!

there are already, IIRC, threads on this topic
Just to inform you - OSMC covers the linux-based OS and Kodi together in one package

The top 3 items might explain things better. The link is also a good bookmark to have handy :wink:

Stim started a very useful thread on this very issue with a link to an install guide

Thanks to you all for your advice.

I already have “How To Set Up Your VPN Client” article from Brian Hornsby, but was a little confused as it refers to Raspbmc and OpenELEC rather than OSMC, and wasn’t sure if this would work for OSMC. I will have good slow look through this as it looks a bit complicated to me (a non expert)!

I also have looked at the following link and can’t decide if this is a workable solution. Are any of you aware of this and whether or not it will work? https://www.dathovpn.com/download-vpn-software.html

Thanks again.

Brian Hornsbys tutorial works fine if you follow the Rsapbmc version and when he writes about /home/pi/ folder this should be /home/osmc etc and ssh of course is osmc osmc. Even his add on works great.

Thanks for your reply. I have now had time to look through Brian Hornsby’s tutorial and this looks reasonable straight forward. I will now give this a go.


I have now followed Brian Hornsby’s tutorial to the letter (I think) and when I get to his “Step 10” to check that everything is working correctly I get the following error messages.

osmc@osmc:~$ sudo openvpn /home/osmc/vpn-config/USEast.ovpn
Options error: Unrecognized option or missing parameter(s) in /home/osmc/vpn-config/USEast.ovpn:2: eg-sec (2.3.4)
Use --help for more information.
osmc@osmc:~$ sudo openvpn /home/osmc/vpn-config/UKLondon.ovpn
Options error: --crl-verify fails with ‘/home/osmc/vpn-config/crl.pem’: No such file or directory
Options error: Please correct these errors.

This is a copy of one of the files:
dev tun
proto udp
remote uk-london.privateinternetaccess.com 1194
resolv-retry infinite
ca /home/osmc/vpn-config/ca.crt
remote-cert-tls server
auth-user-pass /home/osmc/vpn-config/pass.txt
verb 1
reneg-sec 0
crl-verify /home/osmc/vpn-config/crl.pem

Can you see anything wrong?

p.s. I am using an Apple Mac to edit files and communicate with my Rasp Pi using the Terminal App. Also, when editing the ovpn files I had to use MS Word and save them as Plain Text files.

Using MS Word doesn’t sound to good with me, best use text editor on mac, works fine. Or otherwise nano in the terminal.

What does your USEast.ovpn file look like, can you paste the contents here (best in the code brackets)

Also, /home/osmc/vpn-config/crl.pem…is the file actually there???

As TonyFeestneus mentions, you seem to be missing the crl.pem file in /home/osmc/vpn-config/

Use Notepad++ to alter any files. This will save a lot of heartache.

I have just set this all up on my OSMC install now (having previously had this setup with Raspbmc) and it is working fine.

Thanks for your help. I had forgotten to add the crl.pem file as you suggested. I have also re-done the pass.txt file and ovpm files using the Mac’s script editor. I have now completed step 9 of Brian’s tutorial and it now works OK. However, for some reason I am unable to complete step 10, i.e. install the OpenVPM script. I have tried Add-Source but this doesn’t get the required zip file.I have downloaded to my Mac, but am not sure if this is the correct way to get the zip file onto OSMC. I have added other “Add-Ons” without any trouble, ****************, but I’m obviously not properly understanding what I have to do here. :blush:

I would just add it to the osmc folder using FTP and then install it through the interface…

Sorry to show my ignorance, but what do you mean by FTP and add through the interface.
Can I add to the osmc folder via a usb stick? If so then what?

Well, i use an FTP connection to put files on my running rpi2… Google it, it’s easy.

You just have to figure out a way to get the zip file on your device and then install it, with effort you will find out how to do this…

Brian has an explanation on how to install from zip: http://brianhornsby.com/kodi_addons/openvpn

I have now figured it out and everything is now working correctly. I used FileZilla to get the Zip file onto my Rasp Pi OSMC.

Thanks to you and everyone else for your help. :relaxed:

It wasn’t installing from Zip that I had a problem with, it was getting the Zip file installed onto my Rasp Pi in the first place.
This has now been achieved and everything is working correctly.

Thanks for your help.

Good to hear you sorted it out.

I have discovered an issue if yuo wish to use the below method to backup your .kodi folder.

Once OpenVPN is installed the backup seems to complete but reports an error with regards to permissions of the openvpn script. Perhaps @sam_nazarko could kindly advise on how to allow the permissions or alter them.

I have a feeling that it is making a backup of the .kodi folder but unable to backup the openvpn part because of the permissions of the script.

I can post back with what putty spits out tomorrow.

How would one check this has worked? Everything seems to have gone fine, but when I check my IP in “System Info”>“Network” it remains the same? I’m using PIA and have followed Brian Hornsbys guide.