Webbrowser for OSMC / Kodi


I would like to have a Webbrowser on my OSMC / Kodi.
My plan was to use the Chrome Launcher from the super repo, so
I installed chrome so. But when I try to run Chrome it gives me:

This computer can no longer run Google Chrome because its hardware is no longer supported.

So what do I do? What are the alternatives I have?


You wait :smile:

There must be someway to install a web browser to the Debian Jessie…
I wouldn’t mind if it doesn’t launch inside the Kodi…

Or am I getting the wrong idea?

There is, but until we release an official browser ourselves we can’t support these methods.


Would this work?
Install Chromium or some other browser via ssh.
Install the advanced Launcher add on and launch the browser with it.

Or is it not that simple?

Yes, but you’ll need to install X11 behind it which will not be ideal


Why would this not be ideal? And what kind of approach are you intending to take on this?

Because you do not need a display manager for a web browser, and you won’t be taking advantage of hardware acceleration.

Any news regarding OSMC Webbrowser for Vero?

Any news regarding OSMC Webbrowser for RPi2?

Ocelot is still being worked on


Hey Sam. I appreciate all that you do. Just wondering if we could get an official update on Ocelot since the original announced release date has passed. I know I’m curious, and I’m sure others are too:-)

I have parked the project for now due to time constraints


Thanks for the update. I look forward to it whenever you get around to it, but you must be quite busy already:-)

Any luck on this? Would like to use Flix2Kodi with OSMC


Hi same issue here “Chrome Launcher Error” with OSMC 2016.12.-1 on RPi3-B
I am at the end of my rope, as I tried about everything, OSMC working like a charm.
Would like a descent browser that can access Netfix.
Hope you have some solution soon as I have a bunch of ppl very interested in getting a setup like that.
Thank you for the good work & Cheers :beer: