Which protocol to share movies to Vero/OSMC?

I have a new Raspberry 4 with Rasbian Buster and am transferring all of my movie files onto its ext4 mounted disk.

What is the most efficient protocol to share the movies over to my Vero 4K+? Samba ? NFS? Other?

Thanks a lot

NFS will give you the best performance. And we suggest that you use system mounts (via fstab or autofs) instead of using Kodi mounts.

1 Like

Regarding fstab mounts, do you have a document or FAQ which can guide users in what command to use for SMB vs NFS mounts?

Have a look at the wiki on this forum. You will find serveral posts about fstab and autofs and SMB vs NFS.

Thanks Tom and Brian. Very useful info in there. One thing I didn’t see was if FQDN was supported for server name - I’d rather not hard code IP, but I do realize if my DNS server borks then name resolution wouldn’t be able to map it. Thoughts?

Yes, you can use the name instead of IP, i.e. myserver.local I use this for my setup and have never had issues. It just depends on your DNS server/router.

Sorry guys. Where’s the “wiki on this forum?”
This is what I see on my Vero:

osmc@osmc:~$ showmount --exports 192.168.1.74
Export list for 192.168.1.74:
/home/bob/rtorrent 192.168.174.0/24,192.168.1.0/24

this is what I have in Vero’s /etc/fstab:

192.168.1.74:home/bob/rtorrent /mnt/rpi4_movies nfs x-systemd.automount,noauto,user,rw 0 0

and this is the error I get:

osmc@osmc:~$ mount /mnt/rpi4_movies/
mount.nfs: access denied by server while mounting 192.168.1.74:home/bob/rtorrent

https://osmc.tv/wiki/

1 Like

You are missing the / infront of home

1 Like

Thanks modul8. If I search for NFS or fstab or autofs in the little search box on the wiki page you’ve suggested I get no results. eg. https://www.dropbox.com/s/ph1lynraxitx4hx/Screenshot%202020-01-24%2015.41.25.png?dl=0

OMG you are right (as almost always :slight_smile: ). Tired eyes.

Mount works but the filesystem has UID=1001 and GID=1001. tried using the uid=osmc,gid=osmc but they give an error.

Also the mount does not happen automatically on reboot.

Solutions? Thank you

Well you wrote noauto :wink:

How is the setting on your server side? root_squash enabled?

My RPi server has the following /etc/exports content:

/home/bob/movies 192.168.1.0/24(rw,sync,no_subtree_check)

while my Vero’s fstab is as follows:

192.168.1.74:/home/bob/rtorrent /mnt/rpi4_movies nfs noauto,x-systemd.automount,rw 0 0

Is it OSMC on there?

Read the how to to understand the right commands for automount

No the RPi is a Raspbian (Buster) multipurpose server. Vero is OSMC.

So you suggest using autofs INSTEAD of fstab, right?

Thank you very much.

Well not directly as it also should work with fstab (I only saw not the automount part in your fstab). But yes I generally suggest autofs as more stable solution.

For your uid/gid issue read up here. Unless you have matching ID’s on the server (which would be the case if it is OSMC you would need to do mapping.
http://www.troubleshooters.com/linux/nfs.htm

Will study. Thanks a lot. Take care.