Wifi fails to connect after password entry

I have slightly different problem, in that I can see my network but I cannot connect to it. I select it, the dialog for password comes up, select “Done”, and the screen just says “configuring…” for ever. Any ideas?


Please open a NEW, approriately titled thread for issues that are not related instead of thread jumping.


I’m getting the same thing. Can see the network but won’t connect, just keeps saying “configuring”.
256MB Model B Pi, cheap nano wireless adapter that worked fine in Raspbmc.

Strangely, after a while I noticed that I could see samba shares on my network (although I couldn’t connect). I could ping my Pi but couldn’t SSH into it, it just timed out. It seems like the network is half working.

Same problem on Raspberry Pi 2: [RC] Trouble connecting to wifi and not reconnecting on reboot

I had the same problem, it was stuck on “configuring” forever. Another wifi adapter “solved” the issue, it works fine now. Don’t ask me why tough, both adapters are generic cheap wifi adapters, and the first one (the failing one) always worked before with xbmc. Hope this helps!

it wont stay connected for long anyway

Same problem here, RaspberryPi 2 with OSMC RC2 and nothing connected but the WIFI USB dongle. The new Network GUI in RC2 finds the available networks, I can type my passphrase and then a ‘Please wait’ popup appears. This stays working really a long time and then it disappears and the OSMC is still disconnected.

Try setting a static IP instead of using DHCP.

In RC2 there is a known issue with the DHCP client as per Issue with connman in OSMC RC1 & RC2 - #20 by DBMandrake

Please upload your Kodi and System Journal logs. To do so, enable debug mode in Kodi, try to reproduce the connection problem, then plug in Ethernet and use the Log Uploader.

Will do as soon as I get home after work tonight.

While trying it again with debug logs active, it worked. Thanks though :wink:

I have a similar problem. I’m using a PI B+. I can see the wifi networks. I get prompted for my wifi password and then it says the connection failed.
What’s annoying is it’ll connect fine with no security enabled on the router. Obviously, that’s not a long term option. It does imply that the Pi and OSMC are aware of my dongle (Edimax) and how to use it.
Just as an aside, When I connected an ethernet cable, it said it was on the network, but no internet was available. As if to emphasise this, it updated on the unsecured wifi, but wouldn’t even update the time on the ethernet connection.

Please enable debug mode in Kodi, attempt to connect on Wifi to reproduce the problem then upload all your logs using the log uploader. Without logs we can’t make any progress on solving this.

if I enable log debugging can I upload the log after switching off the pi because its freezing so I have to turn it off by the plug. thanks ?

here are my logs http://paste.osmc.io/zeqirarati can someone please help the wifi dongle chipset is rtl 8191su please help guys. thanks

Your issue is NOT the same as OP’s if your system is freezing!! Create a new thread describing YOUR issue in detail please!

  • wifi connection only
  • enabled debugging mode
  • wifi connection with password -> failed
  • connected lan cable
  • uploaded log

this is it
i’m completely stuck with this.


What wifi adaptor do you have and has it ever worked for you on any previous versions of OSMC ?

There seems to be some sort of driver issue there:

May 23 09:06:46 osmc wpa_supplicant[297]: nl80211: Driver does not support authentication/association or connect commands
May 23 09:06:46 osmc wpa_supplicant[297]: ioctl[SIOCSIWAP]: Operation not permitted

Can you paste the output of dmesg soon after booting ?

dmesg | paste-log

Just another data point here. B+ with Buffalo wireless N dongle. Setup can see the SSID but failure to connect when password entered. I was able to successfully setup wireless adaptor using connmanctl. Seems to be working fine now.

sorry man, as written in the other topic i’ve a r8188eu dongle.
It used to work quite well with the old osmc version.

here is my dmesg (hat to connect the lan cable at the end, obviously)