WiFi or No WiFi

I have tried several 11n USB dongles.
I even had one that worked on my Pi2 and on a Pi with the latest OSMC.
It worked yesterday,but not today!
Like the others it does not show under My OSMC network ie only the wired option is displayed.
What happened?

The wifi fairy broke it? Seriously, without logs, your guess is as good as ours.

I have a kodi.log.
I can’t upload it on-line as I do not have an internet connection on the Pi2, which is the problem I would like to resolve (wirelessly).
Unfortunately the wifi fairy is not helping me find any instruction on how to communicate the log via “the official OSMC pastebin” and connecting it to this topic (using my PC).
When I search for help I get a list of topics which do not appear relevant.

It would probably be worth connecting it to a cable for troubleshooting purposes. Alternatively, our log uploader provides an option for saving the log to a file on the fat32 portion of your sdcard which can then be accessed by inserting the card into any PC.

I have done that ie I have the log file.
How do I show it to you?

Paste the contents to paste.osmc.io click the save icon, provide the resulting URL.

Is this ok?