Xbox Remote Not Stable- Recommended Remote For RPi2?

I’ve been using the original Xbox DVD Remote kit (USB modified) with RaspBMC for years now. I’ve just picked up a bunch of Raspberry Pi v2 and have set OSMC RC2 up on one of them.

It took me quite awhile to finally get the Xbox remote to work. I had to use a remote app on my iPhone to go into the OSMC settings and choose the Xbox remote from in there. It took a few reboots, but then everything was working just fine.

I had to reboot the RPi and now it refuses to work with the Xbox remote at all. I’ve rebooted a number of times and it just doesn’t want to work. The Xbox remote is still selected in the settings. There have been a record number of F-Bombs dropped in my house today.

Any suggestions to make this work? I’ve got a handful of these remotes and RPi v2s that I’m setting up for friends and family.

While on the topic… what is the recommended remote to use with the RPi2 and OSMC if I can’t get these Xbox remotes to work?


I use this very cheap remote ($5):

I then had my Harmony Touch learn the commands and can now operate my Pi using my Harmony Touch for $5

Thanks timeanrebel. I actually have the same cheap remote as well, but never use it because I like the layout of the original xbox remote (most of the buttons are mapped perfectly). I did try plugging that cheap one in, but it never worked. Granted, I never tried changing or choosing a different remote in the OSMC settings - maybe that would help?

Is anyone else using the Xbox DVD remote kit with the USB mod on a RPi2 and OSMC without any problems?

try this

Thanks. I should be able to give this a try tonight and I’ll report back.

Worked like a charm! I rebooted 6 times and it worked perfectly each time. I did the same thing with one of the other RPi2s, rebooted it 3 times and it worked every time as well. Thanks!!!

you are welcome :slight_smile: