0x80070035 network path not found

Hi all,

I have my Raspberry Pi 2 set up as an HTPC on my TV. It’s IP address is 192.168.1.114. I can always access it using Filezilla. However, if I try to access it via Network on my Windows 10 computer I often get “Windows cannot access \OSMC.” The error code is “0x80070035. The network path was not found.” If I keep trying eventually I can access it. However, to access the external hard drive (HDD) on the RPi2 I have to go to Devices first. If I try to access “hdd” it asks for my user name and password which is osmc and osmc. However, that doesn’t work.

From Network on the computer I can always access it using the IP address.

Not a big deal but I would like to figure it out.

Thanks.

How are you trying to access it from your “Windows 10” PC? E.g.:

  1. Entering \\name-of-my-OSMC-box\ into the address bar of “Windows Explorer”?
  2. Mapping as a network drive (GUI or command line)?
  3. …?

That error code often means “Windows” can’t look up the IP address associated with the name, which would be consistent with whatever you’re doing always working if you use the IP address.

Without knowing more about your setup there, E.g. how names are resolved to addresses, it’s a bit difficult to give precise information. However you might want to use an elevated command prompt (“Run as Administrator”), go to “%WINDIR%\system32\drivers\etc”, and “notepad hosts”; enter the IP address and name of your OSMC box; write and quit. Then try again - if it is a problem resolving the name to an address, that will fix it for you. But is is a very generic and simple-minded approach to what may be a more complex problem - hopefully not though.

Hope that helps!

I get the error if I go into Windows Explorer and enter \osmc. However, if I enter \192.168.1.114\ it works.

Then I would put:

92.168.1.114 osmc

into your “hosts” file (did you mean “192.168.1.114”?) as per my previous comment.

I believe that will fix it for you.

Here is my hosts file but it’s still not working. Thanks.

# Copyright © 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a ‘#’ symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost
192.168.1.114 osmc
192.168.1.225 downstairs

OK - what happens if you (command window) type ping osmc?

Pings OK.

Microsoft Windows [Version 10.0.10586]
© 2015 Microsoft Corporation. All rights reserved.

C:\Users\Joe Giorgianni>ping osmc

Pinging osmc [192.168.1.114] with 32 bytes of data:
Reply from 192.168.1.114: bytes=32 time=6ms TTL=64
Reply from 192.168.1.114: bytes=32 time=6ms TTL=64
Reply from 192.168.1.114: bytes=32 time=6ms TTL=64
Reply from 192.168.1.114: bytes=32 time=6ms TTL=64

Ping statistics for 192.168.1.114:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 6ms, Maximum = 6ms, Average = 6ms

C:\Users\Joe Giorgianni>

OK, that’s all fine - “Windows” can now convert the name “osmc” into the address 192.168.1.114 correctly.

I know it may sound silly, but have you now tried accessing “\\osmc\” from “Windows Explorer”?
“Windows” keeps a note of which names it has, and has not, found. It will therefore have noted that it previously couldn’t find the name “osmc”. Waiting, rebooting, or entering “ipconfig /flushdns” (if that is, as it probably is, where “Windows” was looking before) should now have fixed the problem.

I tried accessing \osmc\ from Windows Explorer. Did not work. I then ran ipconfig /flushdns and it did work. Rebooted and tried accessing \osmc\ from Windows Explorer and once again it did not work. A few minutes later it did work.

1 Like

I’m sorry @giorgian00 but I can only smile :slightly_smiling: - Welcome to the wonderful world of Microsoft Windows networking :slightly_smiling:.

So … after all the “did … did not …”, is it working now, and does it stay working?

Yeah, I’m no stranger to Microsoft. I became involved with IT when the jan-san company I work for bought our first computer in 1981. I go back to the MS-DOS days.

Anyway, right now I cannot access \osmc\ but, as always, \192.168.1.114\ works.

Heh! You too eh? :slightly_smiling:

OK, it sounds as though “Windows” is still a little … confused.
I assume you’ve got something like a PC or two, plus your OSMC box, all connected to a router - yes?
If I remember correctly, OSMC on an “RPi” supports UPnP and will try to register itself with the router by name. Your router may well then be providing “local” DNS resolution for local devices. MayIf … - this is obviously all highly setup specific (and my knowledge of the details of UPnP device registration is minimal and probably out of date …), so a couple of general things for you to try.

  1. Look for anything UPnP related in the OSMC setup and make sure it’s enabled.
  2. Log on to your router, look for anything UPnP related in the setup and make sure it’s enabled.
  3. Make sure you’ve set the name of your OSMC box to “osmc”.
  4. If you’re using the DHCP server on your router, I assume you’ve got your PC, OSMC, … etc. set up with static addresses? If so, check what properties (E.g., device name) your router may have for that device. If it has any device name associated with it, make sure that is set to “osmc” as well.

If you changed anything anywhere, reboot.

If your router is resolving “local” items for you, if it’s all configured correctly for UPnP, then you should now be able to do this (command prompt on your PC):

nslookup osmc

and you should get your OSMC box’s IP address back. If that works, no matter what weirdness “Windows” is doing resolving the name (and it looks as though it is using DNS from the fact that ipconfig /flushdns made it work … for a while :slightly_smiling:) then it should work anyway as the DNS server on the router should resolve the name “osmc”.

  1. Can I check for UPnP in the OSMC setup from a command prompt via Putty?
  2. On my router (Linksys E2500) UPnP is enabled.
  3. The OSMC box is named osmc.
  4. Upstairs computer is wired Ethernet to the router. Downstairs computer and RPi2 (osmc) both wireless. All have fixed IP addresses.

nslookup osmc returns:

Microsoft Windows [Version 10.0.10586]
© 2015 Microsoft Corporation. All rights reserved.

C:\Users\Joe Giorgianni>nslookup osmc
Server: syr-cf-5000-2.nyroc.rr.com
Address:

Non-authoritative answer:
Name: osmc
Addresses: 198.105.254.228
198.105.244.228

I took out the server address above. It looked public.

If you have more than one OSMC instance you should go to Settings>Services>General and provide a unique name to each OSMC instance, this should update /etc/hostname with the input name

1 Like

Eurgh.

OK, so your PC is resolving names via a DNS server called “syr-cf-5000-2.nyroc.rr.com” - I assume that’s a DNS server which has been provided by your ISP.

As long as you are using an external DNS server, you will have problems using “\\osmc\ ” as a name, because “Windows” will still (sometimes …) try to use DNS instead of taking the copy in your “hosts” file and either be told the name doesn’t exist, or handed back what might well be your public IP address - either way, it won’t work. And “Windows” will cache that negative (or bad) result. That will be why “ipconfig /flushdns” worked (for a while …).

In a “normal” (ha!) domestic situation, at least in my experience, you would use your router as your local DNS server. Your router will handle local queries (E.g., for devices registered via UPnP, and name lookups without a domain), and forward anything else to your ISP’s server.

So I’d try this:
If you have manually configured IPv4 on your PC, change the DNS server to the address of your router (192.168.1. … 1?).
If your PC gets its’ IP configuration via DHCP, change what is given as the DNS server in the DHCP configuration of your router.

Now try “nslookup osmc” (etc.) and see what happens.
(of course, also try visiting web pages, such as this one to reply, to make sure you can still look up any other names! :slightly_smiling:).

When I have Windows diagnose the network error, it says “One or more network protocols are missing on this computer. Windows Socket registry entries required for network connectivity are missing.” Of course letting it repair it does nothing.

1 Like

The funny thing is if I go into Windows Explorer and click OSMC I get the error. If I wait a few minutes it then always opens.

Yeah … “Windows” … :slightly_smiling:

Try changing your DNS settings to use your router as the DNS server - see what happens …