1080p+ with Youtube

I had a play around for an hour or so with various guides and stuff but can’t get YT to work at anything other than 720p. Device is V4k with April update. Its not exactly super urgent, just wondered if anyone had figured this out or if its even possible. Thanks.

It’s entirely possible. Just have a look into the YouTube addon settings and configure the DASH part of the settings to a min/max of 1080p. This should solve it for you :+1:t2:

Hi, i’ve already tried that and a load of other stuff but nothing works. Output is always either 720p, or 240p if i enable the proxy on dash.

Those are the inpustream addon settings I’m using with 1080p resolution here:

Thanks, i’ve tried every combo of settings on this screen and nothing seems to do anything.

I think stream selection should be manual and not auto


Using the YouTube add-on tonight, and tried watching a live stream for the first time on the Vero 4K. Had problems until I found a forum noting that MPEG-DASH needs to be enabled (some entries in the 50+ pages of Kodi Community Forum )

I can now watch live YouTube, but only in 720p

I then noticed that virtually all prerecorded content regardless channel is allowing 720p max (quickest way to test is to select’always ask for the video quality’ under ‘general settings’.)

I found a single recording that offers ‘DASH(mpd; / @0)’ under video quality, and which does output at 1080p.

I tried setting the MPEG-DASH options as you suggested in your reply to the OP in May, and rebooted, but it made no difference.

Any ideas?

Edit: tried the original livestream which started all this. It now offers:
Live@144p, up to Live@720p, (which eventually show a frozen picture a a few seconds of audio).
then DASH(mpd; / @0) which plays at 144p,
and Live@1080p (ts; h.264 / aac@256), which hangs with the rotating busy icon for a while, then exits back to the stream list.

Edit: In the Mpeg-Dash settings I had to put Stream Selection back to Auto to prevent everything being 144p.
For live streams, selecting Live@1080p doesn’t work, but selecting DASH(mpd; / @0) generally gives 1080p…

Prerecorded videos are still stuck at 720p (except the single instance I found which offered Dash as an option)

It depends on what YouTube offers. I find that if you search for 4K videos samples, you will reliably get a 1080p stream. I’d test that first to be sure.



After kicking the settings around a bit, I’ve got the YouTube plug-in (on my Vero 4K+ ) to play 1080p videos consistently.

Is there any way to get it to stream 4K / HDR videos from YouTube?

You can get 4K videos if there is a 4K VP9 encode IIRC.


Do you mind sharing how you did it ?

I was only able to play 720p at 30 fps on vero 4k+ and that’s a video I can watch in 1080p 60 fps on PC.

After searching I found out that Enabling MPEG-DASH and proxy in the youtube addon settings should enable the option to play 1080p videos again.

After doing that a quality option called DASH (mpd) appeared among in the quality option’s select ( before video starts playing )

Since it only says DASH (mpd) and not 1080p I clicked the button with the three horizontal lines on the vero 4k + remote to see stream Info and found out that the stream info now says: H.264 1280x720 px, 1.78:1, 60,00 fps wich means that the fps improved from 30 to 60 fps but resolution is still 720p

My 4K+ has been in for testing. When I get it back, I’ll see if I can get YouTube working again.

1 Like

Got it working as well now

Looks like playing around with the options in “Configure InputStreamAdaptive” inside youtube -> settings -> MPEG-DASH did the trick.

Setting the Min.Bandwidth (Bit/s) to 10000000 and Max resolution for general and secure decoder to 1080p and stream selection to auto did the trick

I know that I will have to change this once I get a 4k tv ( since some people are claiming they got 4k working with youtube ) but for now this works for me

If anyone has any suggestions let me know.

Update: After looking into it a bit more I found out that Min.Bandwidth (Bit/s) can stay at 0 Only Proxy/Use for videos and inputstream.adaptive need to be enabled and installed

1080p works for me now as well, with refresh rate switching in Kodi.

1 Like