[17.5 update 2017.10-1]Broken Playback videos issues

I’m currently not able to resume or fast forward videos.
Most of my videos files over 1Gb won’t start.
My network performance seems to be the same as before 17.5 update (around 6.5 - 7.10 MB over PLC)

Logs are needed so we can identify problems quickly. A full set of logs should be uploaded

1 Like


full log here

Well it would be interesting to know how long the video is to get an understanding of the bandwidth needed.

Other than that I suggest you run iperf3 for 5 to measure the real network throughput



I did a Wget on a large file and this was the write speed on the Vero 4k over a PLC network.
Never had a problem with my network speed before… up to 40GB files
Iperf result : 49.1 Mbits/sec

So are you saying that the videos play fine with Adjust Refresh Rate disables?

I just tried and i doen’t work any better

Which means it is most likely not the same issue as on the other thread.
My gut feeling is still that you have a network throughput issue. I suggest:

  1. You provide debug enabled logs
  2. You do a 5 minutes iperf3 test to check constant network throughput

Iperf3: 49.7 Mbits/sec to OSMC (server)
Iperf3 to NAS (Server) : 65.1 Mbits/sec

That’s quite low — unless you are using something like powerline


Yes i’m using a PLC adapter as i explained it in the 1st post and i had no problem until the last update.
Wifi on 5Ghz is not as good
But my problem is not about my network speed which is enough in this case.
My video playback was broken.
I’ve reinstalled August release, and restore a configuration backup.
Now everything is back to normal.

The generally accepted approach in these cases is to try to run the video from a locally attached disk or flash drive. Have you tried that?

Thanks for the advice. as i said it was working fine before the 17.5 update.
Now that have have downgraded OSMC to the previous build, it’s working again
so OSMC new build has something to do with it…

Are you going to stay on that build?

Before I also restored my configuration file on a new install of 17.5 update 2017.10-1 with the same problem.
For now i think i will use the previous build that is working… but i fear the next update

There don’t really seem to be other reports of significant playback problems post-update.
But unfortunately if you stay on an old version, we won’t be able to fix things.


Sam, i’m willing to help and thanks again for your consideration.

I posted full logs… and reviewed all my setup.
I will try another update tomorrow and will keep you informed.
My only concern is that debugging takes times and can’t watch TV at the mean time.

The logs you provided unfortunately did not have debug logging enabled as per our instructions on how to provide such logs. Without debugging enabled they are less verbose than we need in order to get a good picture of what is actually happening on your system.

Also, you seem to be running a build that is not supported by OSMC or Kodi. That being the case, the first thing we must confirm is that the issue exists without the build or any other illicit repos or addons installed.


Thanks for the insight.
I only playback local files.

Because I’m the only person to have this issue after the update, will it be faster/better for you that i uninstall this and try without it ? or i could make a fresh install ?