2 different "4k" files - 1 plays in 2160p other 1080p

Hi,
Very happy owner of a Vero 4k for almost 4 years now.
I have 2 files - one, which VLC reports as resolution 3840 x 1608, the TV plays in 4k resolution.

Another file which VLC reports as resolution 3832 x 1596, the TV plays in 1080p resolution.

Any ideas on how to troubleshoot this? I’ve been using the Whitelist guide on:

Thanks in advance,
Don.

You should post two debug logs for each file.

That would be expected however, because 4K is 3840x2160.

The logic may have changed recently, but the last time I checked, having an active whitelist would cause that video to be upscaled to 2160p rather than downscaled to 1080p. (Indeed, that’s one of the main reasons for using a whitelist - without a whitelist it would indeed have been downscaled). Has that changed?

Honestly – not sure. Let’s get a debug log and see what’s going on. I don’t have a file with that resolution to hand.

Sam

Thanks for the reply Sam.

Indeed 4k is 3840x2160, so why does the 3840 x 1608 output to 4k but 3832 x 1596 doesn’t? It’s such a small change in resolution.

Will post the log files. Don.

Quick aside: Is there a way to see the native file resolution details when playing the file?

According to https://kodi.wiki/view/Player_process_info pressing ‘o’ should do that. But I don’t have keyboard attached, tried the Kodi remote app, tried to remap a key - no joy.

Thanks,
Don.

On the OSMC remote long-press the info button.

IIRC, to play at 4k, the logic needs at least one of width or height to be 3840 or 2160 respectively, so a video that’s been trimmed in both directions won’t be played as 4k. You can override that by setting the resolution specifically (icon bottom right in the OSD with OSMC skin).

Ah, I see what you mean. Logs files coming up…

I won’t bother you all with the log files as it is quite obvious what the issue is - as grahamh says either the height or width needs to match 4k resolution. As the logs say:

[WHITELIST] Searching the whitelist for: width: 3832, height: 1596, fps: 23.976, 3D: false - no match is found:
[WHITELIST] Matched a desktop resolution with an exact refresh rate 1920x1080 @ 23.98 - Full Screen (23) - But for the other file:

[WHITELIST] Searching the whitelist for: width: 3840, height: 1608, fps: 23.976, 3D: false - we get:
[WHITELIST] Matched an exact resolution with an exact refresh rate 3840x2160 @ 23.98 - Full Screen (36).

I am using the default OSMC skin but don’t see an option in the playback OSD to override the resolution setting. Is it in the Video Settings menu?

I have been doing this, but was wondering if there was an option to show the video stream resolution as show on
https://kodi.wiki/view/Player_process_info

Many thanks for all your help,
Don.

Highlighted below. You must have a whitelist to get it.

Long-press i gives me this.

I am using Whitelist with the default OSMC skin but all I get it:

Long press i gives me this though:


No stream resolution.

Any idea on what is different with our setups?

TIA,
Don.

Looks like one for @Chillbo and/or @darwindesign.

A bit more playing about with the whitelist setting has brought me the playback re-size option.

Many thanks for everyones help.

Don.

I would need to see debug logs to have any insight but are you sure your using the remote that came with the Vero? OSMC loads a special keymap when it sees the official dongle and that has playerprocessinfo attached to long-press i. The overlay that your seeing is playerdebug and with the offical remote that is mapped to long-press home, not i. I find this particularly confusing since I don’t think that action is part of any stock keymap out there other than our current one and I never had playerdebug mapped that way.

I am using the Official Kodi Remote app v1.9 on iPhone (the Vero 4k remote was not working consistently in my setup). That overlay comes up with long press i on the iPhone app.

Any idea if there is a keypress on the app that would bring up playerprocessinfo?

Thanks for your time,

Don.

Mystery solved then as the expected behavior grahamh was talking about is only valid for the OSMC remote controls. The phone apps for controlling Kodi work in a completely different way than a regular remote and they don’t use the keymapping system allowing you to modify them in this way. I don’t think the official Kodi remote app currently has the ability call this action id.