2 Fresh Rpi2 installs today - No wifi TP-Link TL-WN823N

I have today built 2 new Rpi2 OSMC Clients each with a TP-Link TL-WN823N All goes well until I get to wireless configuration. I provided the correct credentials SSID, WPA2 Password at install time. The wireless config dialog show the SSID of the network int eh right hand pane but fails to connect with the correct password. I tried a hot spot on my phone and that also fails to connect. It seems to be trying to connect but try as I may all I get is connection failed. I also tried my edimax adaptor and that does the same thing.

What am I missing, these are out of the box installs with supposedly known working adaptors. The only config done is the locale, Language, country timezone and then into networking. Surely this should wotk now without some kind of black magic required to enable wireless!

Completely useless for thus use cases, I will have to resort to powerline adaptors otherwise, more expense and complexity.

I may be missing something stupid, I have only used Rpi;s for XMBC/KODI/OSMC wired before.


Any help appreciated.


From your logfile:

osmc wpa_supplicant[358]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:18:4d:0f:2c:e6 reason=0
osmc wpa_supplicant[358]: wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
osmc wpa_supplicant[358]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=1 ssid="TWHGHOUSE" auth_failures=1 duration=10 reason=WRONG_KEY

Maybe your keyboard-layout wasn’t correct at the moment you entered the password the first time. Maybe you’re using a qwertz and OSMC expects a qwerty? Try an easyer password in the router to find out that can be the problem.

Hope this helps you


Thanks for the note. I can assure you the password is correct! Keyboard types the correct sequence I checked using another dialog.