2 x Pi3 running OSMC. Can't connect to each other?

2 x fresh install of OSMC updated with November release.

Both have SMB service installed and I can access the auto-mounted volumes from my PC. I have made sure that all devices are in the same workgroup. UPNP and zeroconf are also enabled.

Neither Pi can see any SMB shares on ANY SMB device (PC or OSMC).

I do not know if it is relevant but both are networked via wi-fi with fixed IP addresses.

A port scan shows 21(fTP), 22(SSSH), 80(HTP), 111(rpcbind), 139(netbios-ssn) and 445(microsoft-ds, SMB directly over IP) are all open.

Add source, SMB comes back with zero devices seen.

Add source, zeroconf can see the volumes on the other Pi but if I try to add one I get a “File exists” error???

What is going on?

SMB1 Which is needed to browse SMB has been disabled in Kodi for safety reasons. You either have to manually enter the SMB path or you need to force the usage of SMB1 via settings

Thank you.
How do I force it? I am not concerned about security in this environment.

To do so go to Settings -> Services -> Samba Client -> Max Protocol.

They are both currently on SMBv3. Should I select v1 or v2 instead?

You got the answer already :wink:

Hmmm. A bit borked but kind of working.

Add source, SMB comes back with 2 workgroups seen. My home workgroup and the default WORKGROUP. Both Pis show up in WORKGROUP even though the config screen shows my home workgroup. The presence of WORKGROUP is intermittent, sometimes it appears, sometimes not.

Add source, zeroconf can see the SMB shares on the other Pi and is a LOT faster then browsing SMB.

I have managed to add the sources then play media from the other Pi.

Do I need to SSH and modify a config file somewhere to edit the workgroup name?

I did find the following which appears to have the wrong protocol but no workgroup name.
lock directory = /home/osmc/.kodi/.smb/
client max protocol = SMB3
name resolve order = bcast host
include = /home/osmc/.kodi/.smb/user.conf

The server config is in /etc/samba/smb.conf

1 Like

That worked. Thank you.
It is a shame the OSMC SMB config screen does not do the job properly.

I think its a case of the MyOsmc affects the SMB client settings, but when you install the SMB server from the app store you have to configure that yourself where it doesn’t behave as you wish. There used to be an extra file in /etc/samba to add local settings, and that is where I set my workgroup for the server and some other site preferences (overriding the /etc/samba/smb.conf)

From what I have learnt during this. A copy of /etc/samba/smb.conf needs to be mace called /etc/samba/smb-local.conf with the ‘source’ first line removed or commented out. Changes made here are permanent and not overwritten by upgrades.

You have the main idea. You only need override lines in the smb-local.conf (like the workgroup name).
Good luck with your configuration