[20.5] Audio issue when resuming

Since the 20.5 update, my Vero 4k+ is having an issue resuming some audio after a pause. I hit pause, wait for the blank screensaver to start after a minute, then wait 15+ seconds. At that point, I hit a button to turn off the screensaver and hit play. The video still shows as frozen for a bit, then video resumes without audio, followed by the video freezing again (still no audio), then audio resumes without video, then the video returns, pretty much caught up. The time this entire sequence takes seems to be somewhat random. I’ve had it take 15 seconds or 2 1/2 minutes.

I’ve found that this only happens when hardware acceleration is enabled AND the Unpause Jumpback addon is enabled. I have the addon set to wait 4 seconds after pause and then jump back 10 seconds. If I disable HW acceleration, the addon jumps back without issue and everything resumes as expected and immediately. If I resume before the addon kicks in to jump back, it also resumes just fine and immediately. So far, I can confirm it’s happening with DD, DD+, and AAC. Resuming works with DTS-HD MA. Disabling passthrough has no effect.

Debug: https://paste.osmc.tv/gafewuqeqo

MediaInfo for file with AAC: https://paste.osmc.tv/xizifelema.rib

MediaInfo for file with DD: https://paste.osmc.tv/zamikoteno.vhdl

Update: I’ve now seen that the issue occurs with any rewind after playback is paused. So, the jumpback addon is irrelevant to this issue.

Sounds similar to this Skipping 10s and pause issues since April update - #2 by gigidy56574

@sam_nazarko I sent you a pm with a video of the issue. Is there anything else I could provide that would help the team to replicate and correct this?

A sample would be great,

Here ya go, Sam.


@sam_nazarko Not being pushy, as I’m sure there’s always a lot going on, but let me know if there’s anything else I can do or provide to assist with this.

Will do,

The first thing I’d suggest is trying with Kodi v21.

Keep in mind this is currently in testing; so you may not wish to update yet. We will have a test thread available shortly and I’ll post here when it’s available



Thanks for the tip, Sam. I think I’ll wait a bit, still, though.

That’s fair enough. I’ll still give you an update


1 Like

I figured we should get this solved for Kodi v20.5 as some may not wish to update to v21 yet.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.


1 Like

Sounds great, Sam. I’m currently on vacation and won’t be back until next month, but I’ll give this a try shortly after I return.

Enjoy your holiday, but we will have Kodi v21 way before then.

Thanks. Ah…oh well. Sorry I couldn’t help. Maybe someone else will be able to test it out for you in my absence. Otherwise, I’ll test out whatever’s available when I get back

Cheers and no need to apologise :slight_smile: