2015.12-4 Theme Issue

Hi all,

Had my OSMC install on my Vero die on me so just did a fresh install of the latest stable update 2015.12-4 from the Windows installer.

After starting up the Vero I’ve noticed the OSMC theme is not looking right. The colours are all off which makes it hard to navigate the menus as the white text is almost the same as the highlighted/selected colour. In some of the sub menus such as when you add a source the theme turns black and white but again I cannot really see what I’ve selected.

Is there a known issue here or has my install not gone quite right? It’s almost like the contrast is way off but I have other devices hooked up to the TV and those are fine.


Hi David

Can you take a photo? I haven’t heard any reports of this.

Also let us know if switching to Confluence helps.

If you were on an old version of OSMC on Vero before, you may need to adjust the output colour range. We use the full colour range by default now. Try putting mxc_hdmi.rgb_quant_range=limited in uEnv.txt

Thanks for the reply Sam. I’ll try and take a photo for you tomorrow night.
I switched to confluence and the colours all seem fine so maybe it’s the full colour range and my crappy TV :stuck_out_tongue: Will give that setting a go.

Hi there, I’m having the same issue (from reading the description).

After the last update, the OSMC skin wallpaper is much darker (see first picture) and the contrast of highlighted elements in some lists doesn’t look right. In the second picture, “OpenSubtitles.org” was highlighted out of the 3 Services on the left hand side list but it was nearly impossible to tell apart.

I never changed any skin setting and resetting the OSMC skin to defaults doesn’t fix it.

Colours during playback look alright.

Edit: I run OSMC on a Raspberry Pi 2.

When did you do your previous update?
The only change to the skin is already half a year ago.

I install the monthly updates as they come out.

If I uninstall the OSMC skin, will it be available to reinstall in the skins repo (I can’t check right now)?

You can’t uninstall the OSMC skin within Kodi.

I see, thanks. Any other idea on how we can fix this?

Can’t see anything that would immediately cause this. When did you first notice this? Can you name a specific update?

I installed an update around 10 days ago and the next time I rebooted the Rasbperry Pi 2 the skin started looking like this.

Can you cat /etc/apt/sources.list && dpkg -l | grep mediacenter-skin-osmc



osmc@osmc:~$ cat /etc/apt/sources.list && dpkg -l | grep mediacenter-skin-osmc
deb http://ftp.debian.org/debian jessie main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

ii  mediacenter-skin-osmc                3.1.0-1                     all          OSMC skin for mediacenter

Another thing I’ve noticed is the “Customise Home Menu” inside Skin Settings looks broken:

Thanks, will investigate


Unlikely to fix it unless it got corrupted somehow, but you could try this:

sudo apt-get update
sudo apt-get install mediacenter-skin-osmc --reinstall

That totally fixed it. Thanks!

Sorry to renew an old thread but I’m still having issues with this.

Installed the latest update from scratch and I still have the same washed out menu systems most notably in the File System menu where it is pretty much impossible to tell what you have selected.

I reinstalled the skin as suggested and added mxc_hdmi.rgb_quant_range=limited in uEnv.txt. I added it to a new line in that file if that was correct?

If anyone else wants to try this you have to mount the first partition of your SD card as so:

sudo mkdir /media/tmp
sudo mount /dev/mmcblk0p1 /media/tmp

You can then get to uEnv.txt through /media/tmp/.

Any other ideas or is it just my TV? I don’t think I always had this issue with OSMC though.

Hi – to clarify, are you on the latest Vero update?

What TV do you have, and what are the Settings on it? I haven’t really seen any reports of this issue in some time.


Thanks for the fast reply Sam.

Yup the latest 2016.05-1.

I’ve got an old LG 720p TV. It seems fine with everything else just the menu system.

Attached a pic but it’s hard to tell anything is selected.