2018.03-2 update and no HDR

Just thought I’d report on an issue I’m experiencing since installing the the 2018.03-2 update - any 4K HDR file I play via my Vero 4K is no longer recognised as ‘HDR’ by my TV.

The TV is set to 1080p 60hz for the main Kodi display setting, and set to ‘adjust display refresh rate’ to ‘on start/stop’. However, since the .03-2 update, the display will only adjust to ‘3840x2160 / 24hz’ with no HDR, and oddly the TV changes the display rates ‘twice’.

All was working fine previous to this update. I’ve tested this with multiple 4K HDR files and all exhibit the same issue. I’ve changed no other configuration settings. Oh, and for your reference I have a Panansonic 55EZ950 OLED panel.

Any ideas Sam?

Have you tried updating your device via My OSMC -> Manual Controls -> Check for Updates now?


My HDR isn’t recognised either since the update. LG OLED65GXT.

No manual update available Sam

Performed a manual updated, and no luck. If anything, it’s worse. Still no HDR and 24hz movies playing at 50hz.

Sam, I understand you’ve identified an issue with the kernal and a fix is on the way. Fingers crossed.

That issue should now be resolved and one final update should fix this for you.

Fixed! Thanks Sam.