2021.08-1 Release broke 4k and HDR on Vero 4k + LG CX TV

First: Thank you for an excellent product. In my 5+ years of owning Vero devices, I’ve never had a problem.

My Vero 4k has been working wonderfully for quite some time. I decided to upgrade to the Kodi v19 release before it was stable, and 4k and HDR no longer worked (1080p was the max resolution detected). I wiped my Vero and re-installed the 2020.11-1 image and all was well.

Fast-forward to now, I upgraded to the stable 2021.08-1 and once again have the same problem. For background, my Vero 4k sits in a network closet, and I have an active fiber 18 gbit HDMI cable terminating behind my TV, which couples to a short 48 gbit HDMI cable to the TV. If I take the Vero out of the closet and plug it direct into the TV, it works fine with the short 48 gbit HDMI cable. I wasn’t able to test a direct run with the fiber HDMI cable because my wiring is complicated.

I do realize that my wiring is a variable, but this setup reliably works with the older release, so it seems like there could be a software-based solution to my problem. Is there a way to override OSMC’s detection and manually set the resolutions and HDR support?

Logs: https://paste.osmc.tv/aramatiqes

1 Like

Hope the commands haven’t change but you could try

With the Vero connected directly to your TV and working
echo save bin edid.bin | sudo tee /sys/class/amhdmitx/amhdmitx0/edid

With the vero back connected through the HDMI/Fiber cable

echo load edid.bin | sudo tee /sys/class/amhdmitx/amhdmit0/edid

Thanks for the quick response. I did the following:

  1. Save EDID while directly connected to TV
  2. Move Vero to the HDMI/Fiber cable and reboot
  3. Load “good-edid.bin”, restart mediacenter
  4. Attempt to play video, and TV goes blank (HDMI signal lost)

So the EDID saving/loading seems to work because disp_cap gets updated. I noticed that I needed to restart mediacenter, otherwise the old behavior (1080p without HDR) is used when playing the video. I took a log snapshot after step #4 above.

https://paste.osmc.tv/nutuheweqo

EDIT:
I suppose a next step could be keeping the Vero directly attached and make sure it works with the manually-loaded EDID. Also, if the EDID bins are compatible, I could dump the EDID with the Fiber cable on 2020.11-1, then load it on 2021.08-1?

On the other hand, if it works perfectly with one cable and doesn’t work with the other cable, how can the problem possibly be anything except the cable?

It’s characteristic of HDMI cables that they either work or they don’t, with nothing in between. If a cable is right on the cusp of not working, it can still appear perfect; but the tiniest change to signal amplitude or timing can push it from just-barely-working to not-quite-working, which makes the difference between a perfect picture and no picture. But in order for the cable to be just-barely-working in the first place, it must be already be problematic or out-of-spec.

Fibre cables can be particularly twitchy, because they’re never actually in spec in the first place; the way they work isn’t allowed by the HDMI specification. They’re active devices, which draw power from the HDMI socket, acting as an HDMI sink at one end which accepts the signal, converts it to optical pulses, and sends them along a fibre; another active device at the far end acts as an HDMI source, which converts the optical pulses back to HDMI. They are designed only to be plugged into HDMI sockets, not into other cables, and even then they can be temperamental. I’ve had devices in the past that work fine with a conventional cable but can’t get a signal through a fibre cable.

I’m honestly surprised this setup ever worked in the first place.

It works flawlessly with the older software, and not with the newer software, so I can flip your argument around and say that the software is a contributing factor. I do understand the point you’re making, and I already acknowledged that my hardware is a variable. I did not try to point fingers in my original post, and instead asked if there was a fix I could do on my end to correct for my environment. I don’t know if there is a language mismatch here, but your reply was not received as helpful.

If I can’t find a software solution to my problem, then I will probably try changing the 3-piece cabling (fiber → coupler → short) to a 2-piece solution by swapping the coupler and short HDMI cable for a high-quality extension. If that doesn’t work, I may relocate the Vero behind the TV, but that’s my last resort. I’m stuck w/ the fiber cable because it’s a 75ft run behind my walls.

You might be better off using some kind of HDMI booster or active relay in between the fibre cable and the wired one, instead of a passive coupler.

EDIT: This sort of thing; http://gigabitaccelerator.com/

Thanks - that’s a good idea. I already ordered the HDMI extension, but I’ll give something like this a shot if the extension doesn’t work.

I mentioned that specific device because it came up in an article on the testing of HDMI fibre cables a few years ago - it was able to extend the distance over which some of them worked reliably.

See the attachment to the first post here: TEST REPORTS | HDMI CABLES WHICH PROPERLY AND RELIABLY SUPPORT 18GBPS & HDMI 2.0b | AVS Forum

But generally, fibre cables are designed to connect directly to the HDMI socket of an HDMI sink device. Sometimes they actually need to draw power from the socket (and it’s tough to pull power back through another cable); even if they don’t, the level of signal at the output is designed to be enough to be picked up if it’s fed directly into the socket; it’s not designed to be strong enough to be fed through another cable first.

It’s possible that some cheaper active device (a simple HDMI splitter, say) would do, I don’t know.

I thought it’d be good for me to follow up with the conclusion of my story.

I tried to downgrade back to the 2020 release, and strangely this time it didn’t work. Specifically, I could play 1080p content fine, but my 4k content resulted in “no signal”. I didn’t narrow down if it had anything to do with HDR. I tried using the new extension cable I got in the mail, but that didn’t help. I then took apart my whole setup to do a straight run from the Vero to the TV over my 75ft fiber cable and it STILL didn’t work. I noticed that the Vero side of the fiber HDMI cable was very warm to the touch. I suspect somewhere along the line, the fiber cable got degraded. This is really unfortunate since it was only installed a year ago, but oh well. I’ve got extra CAT6 runs in the wall, so I can do HDBaseT if needed.

I ended up moving the Vero to the mini wiring closet behind the TV, and directly wiring it to the TV with a passive cable. All is well now.

2 Likes

Thanks for sharing this conclusion. Let it be a reminder to people that in the computer world, sometimes an update that you just know caused a new problem may not actually be at fault. Things fail, and Murphy’s Law tells us that those things will fail simultaneously when you did the unrelated update.

2 Likes

Thank you for this update.

We’re always around when you need a hand

Cheers

Sam