2023.08 update fails on raspberry pi 3

I’m trying to update my pi3’s osmc from 2023.07 to 2023.08. I’m using MyOSMC → Manual update. There are downloading messages, but reporting always 0MB at 0bps. Network is working fine (I can stream internet videos without problem).

I tried multiple times - always with the same result. There is no error message within kodi.log. Enabling debugging only adds messages like

2023-09-21 10:20:16.958 T:25690 debug <general>: script.module.osmccommon[osmc_comms] : Connection received partial data... ["progress_bar", {"percent": 100, "heading": "1 / 6 items -- 0 kBps -- 0.0 / 0.0MB", "message": "Updating: nightly InRelease"}] @ /var/tmp/osmc.settings.update.sockfile

The soccket is existing and is owned by osmc, i.e. writable.

Any hints?

Regards, Michael

Reboot and try again. If that fails, upload some logs.

Have you tried at the terminal?

sudo apt-get update && sudo apt-get dist-upgrade

Good hint - there seems to be a signature problem with my smart home environment fhem. I’ll check that …

Fehl:5 https://debian.fhem.de/nightly InRelease Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 801E5B6824562B80

I could resolve my problem. If debian apt encounters any wrong/outdated key it rejects to update anything. In my environment I could update the outdated fhem key as root by
wget -O- https://debian.fhem.de/archive.key | gpg --dearmor > /etc/apt/trusted.gpg.d/fhem.gpg

Thanks a lot for pointing me into the correct direction, Michael

1 Like