21:9 ultrawide support 2560x1080

is ther any update to this working out of the box

2560x1080 or 3440x1440.

I can only assume this is for Kodi, if rasperi pi works with this (using Kodi or Raspberry Pi OS) can you let me know.


Have you tried the 4.9 kernel, there are more video modes supported there.


i actually don’t own the item, i was hoping to confirm with people that have it before i buy it.

maybe it’s all working anyway, there was one thread where someone said it wasn’t working and needed support for it but it’s years old now.

i thought it would just read EDID and allow any resolution the monitor can do.


I don’t think you’d specifically want to use either of these resolutions unless you were watching content in this format, or do you just want this for the GUI?

From what I can see, kernel 4.9 has support for 2560x1080p60hz, 25601080p50hz. Likewise for 3440x1440p60hz.

Full list is:

static struct hdmi_format_para *all_fmt_paras[] = {


it’s just to send that signal to the monitor, so it can use the full 21:9 panel that is native ultrawide, as in the monitor is in that aspect ratio.

I take it this woul work with rasperri pi as well?

You could use a custom mode on the Pi I believe, yes.
But I’m not sure if GBM (used on Pi) will handle it properly with Kodi.

ok would 2560x1080 work with Vero 4K+

It should be possible – because there is a modeline for it.
But you will need Kodi v19/ kernel 4.9 which we will ship as stable later this week


ok, its important as every other commercial set top box (fire tv, android) don’t support ultrawide, its all 16:9, standard media players are also in a similar boat.

vero+ is the only hope for it, along with HDR.

a silly question but could it handle 5120x2160, my guess is not as you need display port, but do you know if any rasperi pi or vero may have display port in the works.

Max supported output on 4K/4K+ is 4096x2160 (SMPTE)

We won’t move above 4K in terms of output resolution for the forseeable future.


did you managed to confirm 2560x1080 is working with the 4k+ with the new update you released yesterday?

I don’t have a monitor that supports such a resolution, but the support is integrated in to the 4.9 kernel now.

ok thanks

ok i have the latest kodi installed, i select this resolution and the screen is broken, see screenshot

Not quite. It doesn’t make up timings on the fly. If you send us your edid we can see what’s happening.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Type cat /sys/class/amhdmitx/amhdmitx0/rawedid and post the result here.

ok well i have 2560x1080 running anyway and when i select it the screenshot above is what i see, has anyone elese tested this resolution?

If you want us to help, please post the information I asked for. It’s possible your display is using non-standard timings.

started it up today
splash screen kept pressing esc, didn’t get command line, just standard screen
tried 2560x1080, it changed, had to pull power plug in/out as no off switch
splash screen kept pressing esc, just cut out, got unhappy face 3x, had to pull power plug in/out as no off switch
all i get is unhappy face now.

keep in mind splash screen is cropped, i can’t read the information at the top, i will move on to 16:9 screen to see the whole screen soon, to check if command line can work.

Have you tried to login via SSH