2160p playback problems

I am having problems playing 2160p files.

If I start the movie from the beginning it’s fine. But if I try to forward it, click “resume from”, the box will either crash, get stuck on the ‘busy’ signal or takes several minutes before it plays.

Anything I can do about this please?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


Does this only occur with the Resident Evil movie?

Did you restore your Kodi userdata from another device?

I can see a crash of your embuary skin, does your issue also happen when you’re using the OSMC skin?

2023-07-22 21:15:35.678 T:3473    error <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'AttributeError'>
                                                   Error Contents: 'datetime.timedelta' object has no attribute 'tzinfo'
                                                   Traceback (most recent call last):
                                                     File "/home/osmc/.kodi/addons/script.embuary.info/default.py", line 7, in <module>
                                                       from resources.lib.helper import *
                                                     File "/home/osmc/.kodi/addons/script.embuary.info/resources/lib/helper.py", line 15, in <module>
                                                       import arrow
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/__init__.py", line 2, in <module>
                                                       from .api import get, now, utcnow
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/api.py", line 12, in <module>
                                                       from arrow.arrow import TZ_EXPR, Arrow
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/arrow.py", line 1703, in <module>
                                                       Arrow.min = Arrow.fromdatetime(dt_datetime.min)
                                                     File "/home/osmc/.kodi/addons/script.module.arrow/lib/arrow/arrow.py", line 318, in fromdatetime
                                                       if dt.tzinfo is None:
                                                   AttributeError: 'datetime.timedelta' object has no attribute 'tzinfo'
                                                   -->End of Python script error report<--

I’ve only tried a small amount of 2160p as it always error’s, I thought I’d give it another try with the Rest Evil movie and 2160p is still giving problems.


The issue happens with both Metropolis and OSMC skins - I haven’t tried any others.

Can you try another HDMI cable?

Done - same problem.

I would suggest trying to reinstall OSMC. Nothing obvious sticks out to me in these logs.

1 Like