2xRPi3 running OSMC, one fails to connect WiFi

Have searched for my particular problem, but found nothing specific in the threads, so open my own. I am running OSMC on two identical RPIs, each in a separate location. The one runs the feb update OSMC, and wifi is not a problem in either of the two locations. The other was fresh installed with the april update, runs well wired, but when attempting to connect wifi, I get a quick message along the lines: “Unhandled Exception Caught - see log”. I have a minimum of peripherals, use FLIRC on both, sometimes a wireless keyboard. RPi #2 has fewer addons and only from Kodi repo, no VPN, which is not the case with RPi #1 which runs faultlessly. I have tried entering the password using English QWERTY as well as various Scandinavian ditto, the result and the message remain identical. I have uploaded the .kodi log, but how on earth you’ll be able to find that at your end is beyond me. Sorry. I realise I’m not actually supposed to clip and paste into the thread, but will give you a short clip from the log that was sent as a taster, and then await instructions on how to coordinate sending the entire log and bind it to this thread. How do you do that?

6:27:12.862 T:1717302256 DEBUG: Unhandled Exception thrown in Networking GUI Traceback (most recent call last): File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py", line 390, in onClick self.handle_wireless_selection(controlID) File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py", line 1188, in handle_wireless_selection self.handle_selected_wireless_network() File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py", line 1267, in handle_selected_wireless_network self.connect_to_wifi(ssid, encrypted) File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py", line 1355, in connect_to_wifi connection_status = osmc_network.wifi_connect(path, password, hiddenssid, script_base_path) File "/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmc_network.py", line 313, in wifi_connect keyfile = open('/tmp/preseed_data', 'w') IOError: [Errno 13] Permission denied: '/tmp/preseed_data'

Hi,

When you uploaded your logs, it would have provided you with a url, to paste here.

You could also try connecting via the command line.

connmanctl
scan wifi
agent on
services
connect MY_SERVICE
enter passphrase

The output from these commands, may gives more of an idea of what the issue is.

Thanks Tom.

I’d suggest a reinstall, a permission denied trying to write to /tmp looks like filesystem corruption to me. If a reinstall doesn’t do it, try a different SD card.

I had the same error on the Pi3 with the most current system today.

IOError: [Errno 13] Permission denied: ‘/tmp/preseed_data’

Only root has write access to that file.
The indirect cause was maybe that I entered the wrong WiFi password into the osmcinstaller.
This password was then stored into the ‘/tmp/preseed_data’.

After I entered the commands provided by Tom above, the WiFi connection works and still works after reboot.

Though:

  • ‘/tmp/preseed_data’ still contains the old wrong password.
  • Security issue: The password ‘/tmp/preseed_data’ is not encrypted, so that anybody who can guess my password is still osmc/osmc may see the WiFi password in clear text.

Since all this makes no technically no sense, apparently there is an incompatibility between osmcinstaller and current system.

  • ‘osmcinstaller -v’ does not display its version. So sorry, can’t tell what version it is.

The unencrypted password is in fact configured in file /boot/preseed.cfg. This is where you have to look if you want to hack other peoples WiFi networks.
.

This post has nothing to do with the original post.

This post has nothing to do with the original post.

Of course it has. The cause of the original error may (or may not) be that during the installation via oscminstaller a wrong password was entered.