3-5 seconds black screen after opening MPEG-4/XVID


I have a 3-5 seconds black screen after opening MPEG-4/XVID/AVI video. Doesn’t matter if it’s the beginning or middle of the video, it shows a black screen, no sound, nothing. I can just jump back 10s to see what happened, but it’s quite annoying. I have (HW) Accelerate MPEG-2 and MPEG-4 set to “HD and up” in the Player Video settings.

Debug log: Kodi v20.2 on Vero 4K+ HDMI-CEC and AVI error - Pastebin.com at time around 21:57.


Complete name                            : video.avi
Format                                   : AVI
Format/Info                              : Audio Video Interleave
File size                                : 351 MiB
Duration                                 : 40 min 55 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 1 198 kb/s
Writing application                      : VirtualDubMod (build 2542/release)
Writing library                          : VirtualDubMod build 2542/release

ID                                       : 0
Format                                   : MPEG-4 Visual
Format profile                           : Advanced Simple@L5
Format settings                          : BVOP2
Format settings, BVOP                    : 2
Format settings, QPel                    : No
Format settings, GMC                     : No warppoints
Format settings, Matrix                  : Default (H.263)
Muxing mode                              : Packed bitstream
Codec ID                                 : XVID
Codec ID/Hint                            : XviD
Duration                                 : 40 min 55 s
Bit rate                                 : 1 050 kb/s
Width                                    : 624 pixels
Height                                   : 352 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 25.000 FPS
Original frame rate                      : 23.976 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Compression mode                         : Lossy
Bits/(Pixel*Frame)                       : 0.191
Stream size                              : 307 MiB (88%)
Writing library                          : XviD 57

ID                                       : 1
Format                                   : MPEG Audio
Format version                           : Version 1
Format profile                           : Layer 3
Format settings                          : Joint stereo / MS Stereo
Codec ID                                 : 55
Codec ID/Hint                            : MP3
Duration                                 : 40 min 55 s
Bit rate mode                            : Variable
Bit rate                                 : 139 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 48.0 kHz
Frame rate                               : 41.667 FPS (1152 SPF)
Compression mode                         : Lossy
Stream size                              : 39.6 MiB (11%)
Alignment                                : Aligned on interleaves
Interleave, duration                     : 24  ms (0.60 video frame)
Interleave, preload duration             : 480  ms
Writing library                          : LAME3.97b
Encoding settings                        : -m j -V 4 -q 3 -lowpass 17 --abr 139

Is there any fix for this or is this the ARM license issue?


Your log starts at 21:57 so that didn’t narrow it down much :grin:

Set your UI to 1080p first off…

More Info

We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate>Always or On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

And removing that very large read factor from your advancedsettings may help a little as well. But as far as the video starting before the refresh rate switching has finished you can fix that by setting a time to delay playback in settings>system>display>delay after change of refresh rate>. If you mostly play content that has a particular refresh rate you can also set your UI’s refresh rate to whatever that is to limit how often it has to change.

A full log might give some more clues.

No licensing issue. A file like that will be software decoded if you’ve selected HD and Up.

I am assuming only these files are affected?

Hi Sam,

Thanks for the reply. Yes, those are the only files affected (I have seasons of them, around 6x15=90 files).

If I turn Accelerate MPEG-2 & MPEG-4 to “always”, the first frame freezes, but the audio is going. Is this expected?

The log I linked is the full log from boot, I just stopped it after the issue was reproduced. What else do you need to consider it “full log”?

Thank you!

Unfortunately it’s a not full OSMC log so it’s hard to tell what the issue is.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

You posted just a Kodi log. If you use the log uploader in My OSMC then it also uploads user configuration and system logs.

Did you change your UI resolution as I suggested and did that reduce the time for the video to show up? Also note that with refresh rate switching enabled there is some period of time it takes for a TV to change its view mode. If your playing a lot of episodes of the same thing you can make it so the switch doesn’t have to happen by setting your UI to the same as what your playing. With the file from this log setting your UI to 1080p @23.976 would be ideal. There is also another option in Kodi’s display settings for pausing on refresh rate switching. If you set this to the time your TV sits on the black screen then it will delay the start of playback so your not missing anything.