3 Main Menu Items not readable

With no change on OSMC/Kodi the main menu items “Music”, “Videos” and “Weather” today use a different text now, shown als rectangular boxes for each character. This also applies to half of the submenu names.

Rebooting does not help.
Seems to be independent of the skin in uses since it shows on OSMC skin and Estuary.

Sounds like what can happen when you upgrade to Leia. Post logs, please.

I upgraded from Krypton to Leia a few dys agao and this effect just appeared today. Why would that be days later?

Anyway, if you already have a hunch: What can be done if it would be that thing that you mean.
That spares us the effort if it is something I can try, let me know.

Without logs, it’s difficult. But first thing is to go into Settings->Interface->Skin->Configure skin->Customize Main Menu

Delete the three items which no longer have text and use Restore menu items to get back Music, Videos and Weather.

You may also have a fonts issue but since I don’t know what language you are using I can’t advise.

deleting the menu items and then restore to default did not help.

Estuary standard font, english (US).

These Menu items are probably set in a different font, if I switch to Arial it looks like some arabic text.

We need to see logs if you wish to further pursue resolution without a reinstall.

Go to settings->Interface->Regional->Language and change “English (US)” to “English”

That worked, but any idea why…?


I tried updating but it had not populated the repository yet. I’m not sure what the difference is anyway between the US and the Queens english in anything that would show up in Kodi so it probably doesn’t matter.

Things like customisation <> customization e.g. will be different.

For the problem just went away during the same day without me making any change. Interesting.

I’m not sure how interesting it is. Someone updated that translation file but made a mistake. The error was discovered and a new translation version was put up in the repository pretty quick. Your issue ‘just went away’ when Kodi saw the updated add-on in the repository and installed it.