3D Frame Pack MVC issue

Tried to play back some 3D MVC isos and couldn’t get it to quite work. It seems to still be sending 2D to my display (JVC NP5) and not going into frame packing output mode. I tried selecting all of the 3D options in the vero/kodi interface and no matter what I selected it seemed to be stuck on Stereoscopic/2D mode (when I think Hardware Based or Same As Movie are my desired modes, can someone confirm?).

I am new to this so I will provide my file workflow. I am trying to remux Atmos into MVC 3D for titles like Avatar which only include 5.1 on the 3D disc. For 3Ds I only have my own backups (BDMV folder, etc.) created from MakeMKV backup feature. For the 4ks with Atmos I have similar backups made from MakeMKV for some titles and mkvs for some other titles. Regardless, I throw them together into tsmuxer, select the 2 vid tracks and subs from the 3D and the Atmos track from the 4k, and remux into a blu-ray iso:

These isos are what I have tried (and failed) to play in 3D frame packing mode with my new Vero V. Currently trying to remux into a .ts and see if that works instead (if not, will try to convert to mkv and try that too…).

Anyone know what I’m doing wrong?


  1. How have you named your files? Are you including ‘.3D.MVC’ in the name?
  2. Can you upload some logs so we can check if your display is advertising Frame Packed support?
  3. Have you enabled frame packed support in Settings?

Do what Sam says. :slight_smile: But also, is there a reason why you need to remux to ISO at the end? In my experience you’ll probably get better results keeping everything in MKV format. Rip directly to MKV using MakeMKV and then remux the audio track in using MKVToolNix.

EDIT: The main settings you need for 3D are:

Settings/Player/Videos: make sure hardware acceleration is on; set “Adjust display refresh rate” to either “On start/stop” or “always”; set “Playback mode of stereoscopic 3D videos” to “Preferred mode”.

Settings/System/Display: under Stereoscopic 3D set “Preferred mode” to “Same as movie”.

Ahhhhh I just got it to work. Thanks for the quick reply. #3 helped… I did not have match frame rate option set to Always. Once I changed it to Always my files are now playing back in frame packing mode perfectly. Depth looks identical to blu-ray player, no issues there. Is that the setting you were referring to (or were you asking me to enable frame pack support in my JVC?).

Just to respond… for 1, no I don’t have .3D.MVC in the name (but it’s working now nonetheless).

Thanks for the tip! Yeah I’ve heard playback is easier on the device using mkv rather than iso. Gonna take you up on this - thanks!

No need if your files have the correct flags set

I’m sorry if I should not be replying here, but, I have been trying to play frame packed MVCs and am having no luck. I have gone through the settings listed above and all are correct, but when I try to play the file the TV says 3d Stereoscopic/2d mode, and all I get is a juddering picture.

Hi @Todge

Hope you are well.

As discussed before, Full SBS isn’t supported at this time, but frame packed MVC definitely is.

We need a bit more information to work out why this is not working for you.

So we can give your issue the attention it deserves, could you please start a new post with some logs. You can learn how to do this here:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

I am confident that we can then get this solved for you promptly.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi Sam,

Sorry for the late reply, health and family issues got in the way…

I have found the problem, files made with CloneBD play in 3D, but the screen keeps refreshing every few seconds and I can’t close the toolbar at the bottom of the screen, but files made with DVDFab play perfectly, so I can simply use that instead.

Thanks for the offer of support, and again, sorry not to get back to you sooner.