3D Frame Packed output

Did you also ran the downgrade sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13

I have not done this. Is that the final step? (does the note in the first post implicate that I should have done that?)

No but it was mentioned in the last release.
So that step currently is needed till a new 3D version is released.

1 Like

@tanio99 Just an fyi…3d issue with descriptors was makemkv issue…


Thanks for that link. That was also my assumption. Anyway, the next testbuild will support both descriptors :slight_smile: .

I have Kodi 18.6 with Kernel 4.9 running on my Vero4K and most of my 3D ISOs work fine.
But none of my 3D MVC MKVs (remuxed by makemkv) are working fine. They are correctly identified as 3D (I get the ‘Select playback mode’ screen) but if I chose ‘Same as movie’ it only shows me half of the screen for the left eye and the other half on the right eye (either only using the bottom half of the screen or the whole screen but somehow split in the middle of the screen).
I have .3D. in the file name, but even adding .MVC. doesn’t do the trick either…

see this post: 3D Frame Packed output - #711 by tanio99

Thanks for the answer, but according to some posts after that one you linked, it should have been already fixed.
So I thought: maybe I don’t have the latest version/fix installed and went to ‘My OSMC’ and manually updated to the latest version. Unfortunately I’m on Kodi 18.7 now and what I’ve read in another thread (written by Sam) there is currently (for a few days?) now way to downgrade…
Seems I’m stuck with no 3D for the next days… or did I misunderstood something?

There will be new 3D builds shortly based on v18.8. You won’t have to wait long, just keep watching the forums


Hi Sam and tanio99,

I’ve upgraded yesterday to the latest test build (18.8) and all my 3D issues with MKVs are gone!

Thank you so much!

Perhaps I missed the announcement, but are you saying that there is a new Vero-4K+ build that has MVC working or are you talking about reverting back to that old build on the newer kernel?


See [TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

1 Like

I’m looking at it right now as a matter of fact!

looking at the updated, original post it seems I can run these commands and it will update the Vero4K+ to the latest version of OSMC on Buster and both 4K and 3D will be supported?

If this is true it will make me very happy and I will hopefully get a chance to try this tonight!

Thanks Sam!

Yes, that’s correct.

Make sure you follow the instructions carefully – or take a backup beforehand and ask us for any further clarification.

OK, thanks!

I am looking at this now. From looking at this it is actually telling me to edit the lines and replace “stretch” with “buster”. Is that correct?

I ask because when I try to run the update via MyOSMC it says that it is “Downloading Update” then I get a message that “cache is updated” then it says that there are no updates available. I am interpreting that to mean I am as up to date as i can be with the current sources list. Is that accurate?

It looks like what I need to do is change the sources to “buster” so it actually can update?

Can’t advise without logs.
Let’s have a look at those so we can advise accordiingly


Sam, I tried to upload logs from within OSMC, but even though it showed upload progress initially, it ultimately gave me the happy, blue screen of death…:frowning:

However, the update seemed to work with a caveat. I got this in SSH when running the updates:


I really didn’t know what this was and opted to keep the default option of retaining locally modified file and moved on. Since I can still connect via SSH I presume that wasn’t the wrong move?

On a happy note, I can now play 3D-MVC with Atmos through the “Plex for Kodi” add-on!!! I am testing on my BenQ 2050 projector. It is not 4K so I’m going to take the Vero down to my living room where I have a 4K LED that is also 3D, but does not have Atmos capability.

I will update when I have more info!

Thank you for giving us back 3D!

Hey Sam,
Thanks for the update! Exciting stuff. I haven’t had a chance to test yet, but I assume there’s still no progress on the micro-code related macroblocking in 3D (i.e. the Avatar problem?)

This is the correct version. You may wish to update via My OSMC instead in the future if you want to avoid such prompts

Not presently, no.