3D Frame Packed output

Thanks for the answer, but according to some posts after that one you linked, it should have been already fixed.
So I thought: maybe I don’t have the latest version/fix installed and went to ‘My OSMC’ and manually updated to the latest version. Unfortunately I’m on Kodi 18.7 now and what I’ve read in another thread (written by Sam) there is currently (for a few days?) now way to downgrade…
Seems I’m stuck with no 3D for the next days… or did I misunderstood something?

There will be new 3D builds shortly based on v18.8. You won’t have to wait long, just keep watching the forums


Hi Sam and tanio99,

I’ve upgraded yesterday to the latest test build (18.8) and all my 3D issues with MKVs are gone!

Thank you so much!

Perhaps I missed the announcement, but are you saying that there is a new Vero-4K+ build that has MVC working or are you talking about reverting back to that old build on the newer kernel?


See [TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

1 Like

I’m looking at it right now as a matter of fact!

looking at the updated, original post it seems I can run these commands and it will update the Vero4K+ to the latest version of OSMC on Buster and both 4K and 3D will be supported?

If this is true it will make me very happy and I will hopefully get a chance to try this tonight!

Thanks Sam!

Yes, that’s correct.

Make sure you follow the instructions carefully – or take a backup beforehand and ask us for any further clarification.

OK, thanks!

I am looking at this now. From looking at this it is actually telling me to edit the lines and replace “stretch” with “buster”. Is that correct?

I ask because when I try to run the update via MyOSMC it says that it is “Downloading Update” then I get a message that “cache is updated” then it says that there are no updates available. I am interpreting that to mean I am as up to date as i can be with the current sources list. Is that accurate?

It looks like what I need to do is change the sources to “buster” so it actually can update?

Can’t advise without logs.
Let’s have a look at those so we can advise accordiingly


Sam, I tried to upload logs from within OSMC, but even though it showed upload progress initially, it ultimately gave me the happy, blue screen of death…:frowning:

However, the update seemed to work with a caveat. I got this in SSH when running the updates:


I really didn’t know what this was and opted to keep the default option of retaining locally modified file and moved on. Since I can still connect via SSH I presume that wasn’t the wrong move?

On a happy note, I can now play 3D-MVC with Atmos through the “Plex for Kodi” add-on!!! I am testing on my BenQ 2050 projector. It is not 4K so I’m going to take the Vero down to my living room where I have a 4K LED that is also 3D, but does not have Atmos capability.

I will update when I have more info!

Thank you for giving us back 3D!

Hey Sam,
Thanks for the update! Exciting stuff. I haven’t had a chance to test yet, but I assume there’s still no progress on the micro-code related macroblocking in 3D (i.e. the Avatar problem?)

This is the correct version. You may wish to update via My OSMC instead in the future if you want to avoid such prompts

Not presently, no.

OK, more testing.

When I update via “My OSMC” it always says “no updates found”. I will continue to monitor the situation. I also uploaded log files (which worked this time), but failed to record the URL to get to them. If there is a way to retrieve it I will do so. Please let me know.

So, I connected the Vero4K+ to my Yamaha RX-V385:

…which then feeds this TV: LG 65UF8600:

Both of these have specs that should accommodate anything the Vero can throw at it. Of course there are variables like cabling etc, but the components would be adequate. I currently have a Roku Ultra connected the identical way and it handles anything a Roku Ultra can send to it without issue. Of course that has minimal support for HD audio, but it’s not the audio I have concerns about.

If I set the Vero to an output resolution of 1080, EVERYTHING seems to play fine. 4K (in 1080 of course), 3D-MVC switches the TV automatically and works great. If I play a 3D-TAB file it displays properly with regard to overall resolution, but I have to manually put the TV into TAB/SBS mode. Not the end of the world, but wanted to let you know in case that was supposed to happen automatically like it does with MVC.

On to the 4K test…

To get video on the Vero on my 4K setup I had to set the Vero to the higher of the two 4K resolution options at 30fps. Last night when I tried this I also set it to force the 422 color, but not sure if that is required.

When I do this I can play 2D anything (4K/1080/SD) fine (no idea if HDR is working or not but the TV is not displaying the HDR logo). However if I try to play 3D in this mode one of two things happens. If I play a TAB file OSMC asks me what mode I want (which I expect) and I get a message on the TV that it is in 3D mode, but BOTH halves of the picture are squashed into the top half of the screen.

If I manually turn off and on TAB mode on the TV itself it doesn’t fix this. If I try a 3D-MVC file the screen goes dark and nothing happens. No audio nor picture. if I hit a button on the remote I can hear the button sound, but I can’t see what is happening if I do. I have to exit out of the movie I’m trying (back button a couple times) and it will take me back to the movie’s title page, but it won’t play.

Is there anything in particular you want me to try for more info?

You should only set the resolution to 1080p and enable Adjust Refresh Rate. Do not set the GUI to 4K

I must have misunderstood something in those settings. I thought the resolution you choose in the OSMC settings was for the output.

Are you saying that setting is ONLY for the GUI, but if I set that for 1080, any 4K movies I play will still be output as 4K to the AVR/TV? If so that is a fundamental misunderstanding on my part! Maybe there should be a note about that within the GUI saying it’s only for the GUI and not for the actual movie output?

What about HDR? Perhaps I’m mistaken, but does the Vero handle HDR and if so, how do I know if a given title is supposed to have it or not?

That’s right, provided you enable Adjust Refresh Rate.

If you play something with HDR properties we will send an HDR EOTF. Usually your TV will also show something like an HDR logo too.

It is a bit more complicated than that. That setting is for the GUI but also sets the output resolution and frame rate of playing video IF you don’t have adjust refresh rate enabled. If you have adjust refresh rate switching enabled then video will be output at the GUI resolution and higher at an optimized frame rate. A whitelist with refresh rate allows for output both above and below the GUI resolution depending on what is set.

If you use the recommended settings your should get HDR output during playback and when the video starts you should see on your LG and black screen followed by a HDR logo in the top right corner display for a couple seconds. If not already enabled on your LG you will have to enable “HDMI ULTRA HD Deep Color” in its menus.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Thank you @sam_nazarko @darwindesign! I have set it to the above settings and it is 99% awesome!

As far as it switching into 3D TAB/SBS automatically, it seems to actually do that with TAB files, but not SBS files. I tried several and that’s what happened, but I will do some more testing.

As far as HDR goes, I think I am getting it. I am just getting the notification so quickly it’s barely noticeable. On my TV it comes in on the bottom right which is below the progress bar etc. That combined with the fact it takes a few seconds for the picture to appear, I think due to refresh rate syncing with the source file. By the time the pic comes on, I just barely catch what I think is the HDR notification.

I have to say, I love it!

How are your files named?