3D MKVs freeze up, only when seeking

I ripped a number of my 3D bluray discs to MVC MKVs, and am having some trouble with seeking, when playing back on my RPi2; OSMC 2017.04-2, no overclocking.
The movies play back flawlessly from the beginning (from NAS, by ethernet via NFS), both in 3D and monoscopic 2D mode, but whenever I try to seek with the arrow buttons on my remote app (up/down 10 min. steps or left/right 30 sec. steps), the movie freezes up, but still shows the first frame from the place, I “seeked to”, even in 3D … (!)
After this, my only option is to start the movie over again. Pausing and then playing back again works normally though, for some reason …

Any idea what this is and what can be done? Kind of annoying to not be able to jump into the movie, where you like …
I noticed some suggestions pointing towards TrueHD audio tracks, but the movies are with both AC3 and DTS core tracks, no TrueHD or DTS-HD-MA.

Heeeeelp :confused:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

1 Like

Thanx very much :slight_smile: I tried uploading a log here:
Hope this’ll be of help … don’t know if I’m doing this the right way.

You are watching 3D mkv on an old style SD TV?

1 Like

Ahem, no … :wink: Not at the time when I made this log.
A few days ago I was watching on a brand new Epson TW6700 3D projector, which is currently being replaced because it was a bad unit.
But I had this issue with 3D MKVs for the 1,5 days I had it at home, both when playing back in 3D or 2D monoscopic mode, and it’s the same now, only with my old retired projector, which can’t do 3D.
Anyway, the issue is still exactly the same … :-/

You mean the log states I’m using an SD tv? Thats weird …

I think I’ve noticed this behaviour as well on the Vero4K (and RPI2). Not a big 3D-fan but I’ve got 1 or 2 MVC MKV’s I can test. As the OP states, when seeking the movie skips to the requested position and freezes.
I will check tonight to be for sure.

1 Like


Can you reproduce the issue, if you playback locally on sdcard or usb flash drive?

Thanks Tom.

The lines I quoted from config.txt just indicate that at one time the device may have been configured for an older tube type TV.

Ok, that makes sense :wink:

Good question, Tom … I’ll try running the file from local memory as fast as I can. Thanx for the input. :slight_smile:

Ok, tried playing the same 3D MKV file from a local USB drive and it’s the same.
But I’ll say anything else would have surprised me, because my NAS never has any trouble keeping up with high bitrate 2D BluRay rips for example …
Weird thing is that I can find no similarities between the files that do work and those that dont.
I thought about audio tracks, but they’re all both DTS or AC3 core tracks, so its not one type that works and the other doesn’t.
If I throw up a log on playback of a file where I have no freezeups when seeking, will that be helpful? I have a single one of those so far (and 5 that don’t work)


Video caching, may show some improvement of the issue.

Thanks Tom.

Sounds interesting … I tried editing the advanced settings.xml with the following result (some other stuff in there too, relating to an add-on)
Does this look right?


Looks ok, except I don’t know if it makes any difference or its just for neatness or readability; it should be tabbed out like this:


Also I’d tempted to adjust the readfactor. I’m using this on my pi3s:


Thanks Tom.

Ok, tried it now, but alas, to no avail, at least as far as seeking in 3D MKVs goes … :-/


You’ve mentioned that the audio codecs are all different, what about the video codecs for 3d mkvs?

Mediainfos may help.

Thanks Tom.

It’s me who says thank you, Tom :slight_smile:
I tried checking Mediainfo and made a comparison, but there seems to be no significant differences between all the files that freeze up and the one that doesn’t …

For all files:

AVC codec
Profile High@4.1
Format Settings, CABAC, yes
1920 x 1080
23.976 fps
24 bit resolution
Colorimetry: 4:2:0
Progressive scan

The only differences I can see are:
ReFrames, most are set to 4, one is 2 and one is 3, but the one file that doesn’t freeze when seeking is set to 4, so …
Then there’s video bit rate ranging from 16 Mbps to 30 Mbps, and the winning file is at 19.6 Mbps, so it doesn’t look like a question of too high bitrate either …

Hmmm …

I think I’ll try and remux one of these guys into a m2ts container instead and see if that changes anything.


It could be the ReFrames, but just co clarify the video codec is the same for all those causing issue?

Thanks Tom.

Yup, AVC all across the board …
But how can it be ReFrames, when I have 4 files all set for 4 ReFrames, and 3 of them are causing the issue, but a single one isn’t? :confused:


Sorry I miss read what you reported the bit about reframes, I thought the one you wasn’t having an issue with; had a didn’t reframe.

I would try remuxing, and see if there is any difference. Could be a codec issue.

Thanks Tom.