3D Movie cannot be set to 2D/Monoskopic


I found one Video that is orignial 3D and i want to watch it in 2D/Mono.

These are the MediaInfos: http://paste.osmc.io/iwetoyosis.vhdl

File is named correctly and in Kodi displayed as a 3d movie.

It is not possible to watch the Movie in 2D Mono while Armcodec Hardware support is enabled.

If i disable the hardware support, the movie can be watched in 2D


Side by Side (left eye first)

The video is SBS. I think your file needs to renamed to 3D.SBS.mkv.

Some projectors or TVs permit a ‘3D->2D’ conversion mode in the menu as well. But were you using that software acceleration works for 2D output, just not amcodec?


I can test it again be renaming it.

It is just not working with armcodec enabled, if it is disabled it plays well in 2D/Mono

Okay – thanks for confirming. I usually watch 3D SBS with amcodec to be output as 3D SBS, so hadn’t noticed this one before.


Ok renaming does not solve it. It seems that the enabled armcodec is the actual problem.

I wrote with sam and we figured out what the problem is, it will be solved with an update.

So i will mark this thread as solved.