3D MVC Playback problems on vero 4K+

I’ve just taken delivery of a Vero 4K+. My main reason for purchase is that it supposed to support 3D MVC playback, wanting to upgrade from my raspberry pi 3b+ and giving up any hope that the 4b will ever be able to do this.

I have around 100 3d movies all full frame packed MVC Mkv files which work fine on my raspberry pi 3. Whilst they play in 3d on vero they look terrible. The picture has random black and white artefacts being displayed when the picture is moving which makes them unwatchable.

Has anyone else experienced this and is there a fix for this?
Since this is the only reason i purchased the hardware its pretty annoying to say the least

I’m running the latest update 19.4.0 (Git: 20220308-osmc)

That doesn’t sound right. I’d suggest posting logs, the name of a title you are trying to watch and some information about what equipment you have


Here are my logs:


The issue has presented on every movie i have tested so far, but here are some of them i’ve tried:

The nightmare before christmas
My Bloody valentine
The Meg

I am using an Optoma HD131X DLP Projector and a Marantz NR1602 Amp. The strange artefects are there even when choosing to play the video’s in 2d on my tv. The only change to my setup is the Vero 4k. The files play fine on the raspberry pi 3b with libreelec. They also play fine on a windows PC with Stereoscopy player

Thanks for the details.

  1. Did you rip these files yourself (i.e. using MakeMKV)?
  2. Can you enable debug logging and reboot so we can get more detail
  3. If the answer to 1) is no, can you provide a link or sample for an affected file, i.e. Sanctum.3d.sbs.mvc.1080.DD5.1.mkv so we can see if it can reproduced here


Hi, thanks for the quick response

  1. Yes i ripped it myself from the Bluray which I own using Makemkv. I then use BDrebuilder to re-encode to save space. I believe it uses FRIM Encoder for the 3d MVC encoding.
  2. Sure. I have switched on debug logging. Here is the new log file https://paste.osmc.tv/sibubipobe
  3. Here is a sample of the file:

Many Thanks

Hm – have you tried a title without this additional post-processing step?

This is neither a properly encoded MVC file, nor a properly encoded 1080p half SBS file… It’s using the AVC codec, is flagged as SBS stereo, has a resolution of 1920x1080 (so only half SBS), doesn’t have a MVC second eye layer, but triggers the MVC hardware decoder (with MVC tag in the file name present and not present - no difference) and plays back here with artifacts as well.

Try playing back the untouched original rip of the 3D disc and it will most likely work… Something went wrong here during the re-encoding. And also leave out the MVC tag in the file name, if the file is not actually an MVC encode. :wink:

I had a quick look at the file. It has a tag set telling Kodi that it’s SBS which leads the 3D detection logic into the wrong direction:

Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : Stereo High@L4.0 / High@L4
MultiView_Count                          : 2
MultiView_Layout                         : Side by Side (left eye first)

As @Chillbo has mentioned, the filename tags tell Kodi that it’s MVC and SBS. I can’t tell which one of these tags override the other, need to look into the code.

When you play that video on a 2D screen you can see that it’s definitely not SBS encoded. I assume it’s MVC. So I would remove all the sbs and mvc tags from the filename and correct the tag in the mkv file directly.

But there’s another issue. Your projector doesn’t advertise any 3D resolutions, you can see this in the logs:

2022-05-23 12:21:07.316 T:2860     INFO <general>: No /home/osmc/.kodi/userdata/disp_cap_3d to read
2022-05-23 12:21:07.317 T:2860  WARNING <general>: Update3dResolutions: No valid 3D resolutions found.

That’s why Kodi can not find a suitable 3D resolution and doesn’t switch into 3D mode. Maybe @grahamh could have a look at the edid? If that info is not in the edid we can use that above mentioned disp_cap_3d file to override it.

I will come back to you tomorrow.

I can’t see the details as the user didn’t reboot immediately before playing the file and uploading logs.

Correction: I see the EDID in the first log - no sign of 3D caps. It seems the Optoma’s caps are not being passed through. What is the connection between the Marantz and the Optoma?

Sorry thats probably my fault as i was at that point playing the video file on my tv (which is not 3d capable) as a 2d file. I can play it again via the projector and repost the logs if that would help? The strange thing is that playing the file as 2d i still get the strange artefacts on screen

The Vero is plugged into one of the HDMI inputs on the Marantz Amplifier and then the output goes to either the projector or my tv via HDMI.

The file is encoded correctly as far as i am aware and with the MVC present:

TSMuxer and MKV both identify the MVC part of the file:

The uncompressed rip shows the same properties with 1920 x 1080 for the AVC and the MVC parts of the file


Ok so i have tried playing an uncompressed rip and yes it does play properly, however this is not a solution for me as I do not have the disk space to re-rip my library of 100 3d movies in full Blu-ray quality! I am sure I can’t be the only person to compress their 3d rips for the same reason just as a lot people run 2d blu-rays through handbrake first to reduce the size. I have backed up my 3d movies like this for some years and have never experienced an issue until now. It just seems strange that they don’t even play properly in 2d - which I have not been able to reproduce on other hardware.

Hi here is a new log file. I renamed the file to remove the “3d” reference and just left in “mvc” and i played it on the projector. It triggered the 3d correctly but am still getting the artefacts/ glitching


To illustrate here is how it looks on the projector when playing on the Vero 4k+ in 3d:

Here is a clip from playing it on my raspberry pi 3b+ with libreelec in 3d which plays fine:

Many Thanks

I think you’re mixing up the different “MultiView layout” values. MVC and SBS are two different layouts and they can’t be used concurrently. Your file is MVC encoded so you may not set the layout value to SBS. You need to use Both Eyes laced in one block (left eye first) as layout flag.

If you’re using SBS then Kodi will signal the Vero that it has to switch into SBS mode and the Vero will signal your projector to switch into SBS mode, too. But the file is MVC and so the output will not be what you expect.

So I suggest to remove the SBS tag from the filename (you can also remove the 3d and mvc tags since they’re not used if there’s a layout set in the file itself). Further, you need to change the layout value to the above mentioned one. I did that using the mkvtoolnix-gui on Linux and then the playback is working, both Vero and TV are switching into the correct mode.

But unfortunately, the artifacts are still there. It seems the hardware decoder can’t decode your clip properly :frowning: . Mediainfo tells me that you’ve used the L4.0 profile for reencoding. Can you give it a try and reencode one of your videos using the L4.1 profile? All MVC clips I’ve got are using that profile and don’t show that issue. I’d like to know if the artifacts are profile related or not.


Thanks but i think the wrong issue is being focused on here. The files trigger the correct 3d setting and they play in 3d. They are indeed flagged with the correct stereoscopy as confirmed by MVKToolnix which i ensure is the case on all my 3d encodes. The only reason that some of my files have sbs in the file name is because libreelec didn’t use to be able to read the mvc tag. As I understand it the encoded flag should be read now in any case and the file tag ignored and hasn’t caused any issues in the past. I removed the sbs from the file name “just in case” but it made no difference,

The real issue here is that my 3d rips do not play properly even in 2d on the Vero 4k+. My understanding is that when playing in 2d it should ignore the MVC part of the file and play the AVC part only? In which case it surely has nothing to do with the MVC encode or the way the file is tagged etc. I have not been able to replicate this issue on any other hardware so far apart from the vero - i have also played them through many different tv’s and media players via plex and never encountered a problem so am at a loss as to why they play so crappy on this device. Since my main reason for buying the Vero4k+ was to play my 3d films - its looking like its going to have to go back!

Ok so i have had a small breakthrough. I turned off X264 hardware decoding in the player settings and the files play fine!! Switching it back on and the random artefacts appear again. Why would this be the case?

Because a hardware decoder is used for MVC decode.

We only play files that are in spec / officially ripped. If you re-encode them with a proprietary compression then it’s not something we are going to be able to support.

You can contact sales@osmc.tv and start a return request within 14 days of receipt of your device for any reason.