3D to Monoscopic 2D Error

I found out that i am unable to watch a 3D movie in 2D when i have enabled ARMCODEC.

I don’t know why but to solve another problem i enabled ARMCODEC, and now since a long time i wanted to watch a 3D Movie but i want to watch in 2D.

With enabled armcodec no chance, even if i choose 3D mode disabled or 2D Mono, i still had 2 pictures. I read in the internet and found out to disable armcodec will solve this problem.

Now i am able to see the movie in 2D but with a really sad performance massiv lag and massive drops.

LGOS:
http://paste.osmc.io/ozamozivuc

MediaInfo:
http://paste.osmc.io/vodonemixe.rib
any ideas?

Can you explain what you want to see in this situation?

Do you mean that you want to see one normal picture, but instead see an SBS image?

I’m guessing your file is encoded in 3D MVC. I added support for this in the Summer, but it’s not always smooth. 3D MVC is presented as SBS or TB on Vero. It’s hard to tell how your files are encoded from the file names in your log. I see some loading errors (over SMB) so I’m unable to see what ffmpeg gets from these files (hints).

Sam

Yes i want to see a 3D file as a normal single Picture 2D. This works if the Armcodec is not enabled, but than it is lagging very bad. If Armcodec is enabled, i am unable to switch to 2D or disable, the 3D.

I can choose it to disable, but there is no difference, i see 2 Pictures side by side, or under the other.

Without Armcodec it shows only 1 Picture but it laggs :frowning:

Can you send me a small sample file that reproduces the problem so I can investigate this?

hm. I try to cut a piece out with some software.

I don’t know which software is good and free to cut out a piece of a full mkv file…

and doesn’t change that the codec etc if i save that piece of file new?

mkvtoolnix should do the trick

Ok i have done a really short piece, but even this view seconds got 50mb.

I hope this will help you.

http://www67.zippyshare.com/v/hb8YbXjM/file.html

With Armcodec not possible to switch to monoskop 2D, without Armcodec bad lags.

Thanks.

Hi

I added this to my list. I will investigate soon.

Since i have Kodi v17 this problem is solved, so it only appears on v16.

I seem to have exactly the same issue with my brand new Vero 4K.

I have several h264 encoded 1080p half-SBS 3D cartoons, however my daughter watches them in 2D. So I always selected Monoscopic / 2D mode and this worked well in OSMC on Raspberry Pi 3.

Recently I decided to support OSMC and bought a Vero 4K. Today I found out that when I select Monoscopic / 2D mode, I still get Side-by-Side picture (UI shows in 2D mode). If I go to Settings -> Player settings -> Videos and set Accelerate h264 to Never, the video shows in 2D. But with HW acceleration enabled, it’s always in SBS mode. I actually suspect that the video is getting showed “vanilla”, so if I would have half-TAB videos they would be shown in TAB mode.

The problem is not with some specific, but with all half-SBS 3D videos that I have.

Any suggestion on how I can fix the issue?

There’s a cheap hack to fix this, which I’ll try and add in the next update

Cheers

That would be great! Can you let me know when the fix is in?

And thanks a lot for your quick reply.

Will do.

Keep an eye out on the blog for update information

Sam

I updated today and the issue is still present. Any ETA on the fix?