422 and 420 output

For 1080p and below, output from the Vero 4K seems to be in YUV 4:4:4 format.

Is it possible to get it to output YUV 4:2:2 or 4:2:0 instead?

echo 422 | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

420 is supported only for 4k50/60

  1. I guess that won’t survive a reboot…? If I wanted to make it more permanent, could I?

  2. Are there any situations in which making it permanent might cause problems?

To make it ‘permanent’ put that line in rc.local. I can’t guarantee it will not be overridden, though. Apart from 10-bit, we don’t use 422 because it’s a complete waste of time.

Similarly, I’ve no idea what problems it might cause - we don’t support it.

Doesn’t that depend on the relative merits of the chroma upsampling algorithms being used? (I’ll grant you, 4:2:0 would be preferable to 4:2:2 if it were an option at lower resolutions).

Although this doesn’t apply to me, in cases where a TV has HDMI inputs that are borderline out-of-spec, one might also find it slightly easier to get a stable connection with 4:2:2.

Well, anyway, you answered my question. :slight_smile: